HDU 1005 Number Sequence(矩陣快速冪)

Mr_Treeeee發表於2020-04-06

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 176161    Accepted Submission(s): 43556


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
1 1 3 1 2 10 0 0 0
 

Sample Output
2 5
 

Author
CHEN, Shunbao
 

Source
 

這種形勢的然後n又非常大的就是構造矩陣然後快速冪了。

矩陣是:A B     和 1 0

  1  0 1 0

原本想用費馬小定理減少時間的,發現矩陣的冪好像是不能降的,沒學過嘛也不清楚,WA了一發。

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
const int p = 7;
int gcd(int a,int b)
{
    if(a<b) swap(a,b);
    return b==0?a:gcd(b,a%b);
}
struct mx
{
    int a[3][3];
};

mx chen(mx a,mx b)
{
    mx ans;
    for(int i=1;i<=2;i++)
    {
        for(int j=1;j<=2;j++)
        {
            ans.a[i][j]=0;
            for(int k=1;k<=2;k++)
            {
                (ans.a[i][j]+=a.a[i][k]*b.a[k][j])%=p;
            }
        }
    }
    return ans;
}
mx mxqkm(mx base,int mi)
{
    mx ans;
    ans.a[1][1]=ans.a[2][2]=1,ans.a[1][2]=ans.a[2][1]=0;
    while(mi)
    {
        if(mi&1) ans=chen(ans,base);
        mi>>=1;
        base=chen(base,base);
    }
    return ans;
}
int main()
{
    int a,b,n;
    while(~scanf("%d %d %d",&a,&b,&n))
    {
        if(a==0&&b==0&&n==0) break;
        if(n<=2)
        {
            printf("1\n");
            continue;
        }
        n-=2;
        if(gcd(n,7)==1)
        {
           // n=n%6;
        }
        a%=7,b%=7;
        mx base;
        base.a[1][1]=a,base.a[1][2]=b,base.a[2][1]=1,base.a[2][2]=0;
        mx ans=mxqkm(base,n);
        int now=ans.a[1][1]+ans.a[1][2];
        printf("%d\n",now%7);
        
    }
}


相關文章