HDU 1005 Number Sequence(矩陣快速冪)
Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 176161 Accepted Submission(s): 43556
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
Author
CHEN, Shunbao
Source
這種形勢的然後n又非常大的就是構造矩陣然後快速冪了。
矩陣是:A B 和 1 0
1 0 1 0
原本想用費馬小定理減少時間的,發現矩陣的冪好像是不能降的,沒學過嘛也不清楚,WA了一發。
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
const int p = 7;
int gcd(int a,int b)
{
if(a<b) swap(a,b);
return b==0?a:gcd(b,a%b);
}
struct mx
{
int a[3][3];
};
mx chen(mx a,mx b)
{
mx ans;
for(int i=1;i<=2;i++)
{
for(int j=1;j<=2;j++)
{
ans.a[i][j]=0;
for(int k=1;k<=2;k++)
{
(ans.a[i][j]+=a.a[i][k]*b.a[k][j])%=p;
}
}
}
return ans;
}
mx mxqkm(mx base,int mi)
{
mx ans;
ans.a[1][1]=ans.a[2][2]=1,ans.a[1][2]=ans.a[2][1]=0;
while(mi)
{
if(mi&1) ans=chen(ans,base);
mi>>=1;
base=chen(base,base);
}
return ans;
}
int main()
{
int a,b,n;
while(~scanf("%d %d %d",&a,&b,&n))
{
if(a==0&&b==0&&n==0) break;
if(n<=2)
{
printf("1\n");
continue;
}
n-=2;
if(gcd(n,7)==1)
{
// n=n%6;
}
a%=7,b%=7;
mx base;
base.a[1][1]=a,base.a[1][2]=b,base.a[2][1]=1,base.a[2][2]=0;
mx ans=mxqkm(base,n);
int now=ans.a[1][1]+ans.a[1][2];
printf("%d\n",now%7);
}
}
相關文章
- HDU 2256Problem of Precision(矩陣快速冪)矩陣
- HDU 2157 How many ways?? (矩陣快速冪)矩陣
- HDU 2276 - Kiki & Little Kiki 2 (矩陣快速冪)矩陣
- 矩陣快速冪矩陣
- poj--2778DNA Sequence+AC自動機+矩陣快速冪矩陣
- HDU 1711 Number Sequence(KMP)KMP
- 矩陣快速冪總結矩陣
- 矩陣快速冪(快忘了)矩陣
- 矩陣快速冪加速最短路矩陣
- 矩陣快速冪最佳化矩陣
- 【矩陣乘法】【快速冪】遞推矩陣
- 演算法學習:矩陣快速冪/矩陣加速演算法矩陣
- POJ 3613 Cow Relays 矩陣乘法Floyd+矩陣快速冪矩陣
- HDU 4549 M斐波那契數列(矩陣快速冪+費馬小定理)矩陣
- BZOJ 3329 Xorequ:數位dp + 矩陣快速冪矩陣
- 從斐波那契到矩陣快速冪矩陣
- 第?課——基於矩陣快速冪的遞推解法矩陣
- 費馬小定理 + 費馬大定理 + 勾股數的求解 + 快速冪 + 矩陣快速冪 【模板】矩陣
- bzoj4887: [Tjoi2017]可樂(矩陣乘法+快速冪)矩陣
- HDU 2197 本原串 (規律+快速冪)
- BZOJ3329: Xorequ(二進位制數位dp 矩陣快速冪)矩陣
- POJ 3233 Matrix Power Series (矩陣快速冪+等比數列二分求和)矩陣
- HDU - 1061 Rightmost Digit(二分快速冪板題)Git
- P1005 [NOIP2007 提高組] 矩陣取數遊戲矩陣遊戲
- HDU 6274 Master of Sequence(思維+樹狀陣列+二分)AST陣列
- HDU 6047 Maximum Sequence (貪心)
- HDU 6299-Balanced Sequence(貪心)
- bzoj4547: Hdu5171 小奇的集合(矩陣乘法)矩陣
- 快速冪
- 快速乘/快速冪
- HDU2665 Kth number【主席樹】
- NYOJ 1409 快速計算【矩陣連乘】矩陣
- 2020HDU多校第三場 1005 Little W and Contest
- 巨大的矩陣(矩陣加速)矩陣
- 鄰接矩陣、度矩陣矩陣
- 快速冪模板
- HDU 3006 The Number of set (狀態壓縮)
- 奇異矩陣,非奇異矩陣,偽逆矩陣矩陣