HDU 1711 Number Sequence(KMP)
Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 27986 Accepted Submission(s): 11777
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one
K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N].
The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
Source
KMP,返回第一次出現的地址。只是不是字串而是int陣列而已。
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
int x[1000000+5];
int y[10000+5];
int l1,l2;
int nxt[10000+5];
void kmpnext()
{
int i=0,j=-1;
nxt[0]=-1;
while(i<l2)
{
while(j!=-1&&y[i]!=y[j])
j=nxt[j];
nxt[++i]=++j;
}
}
int kmp()
{
kmpnext();
int i=0,j=0;
while(i<l1)
{
while(j!=-1&&x[i]!=y[j])
j=nxt[j];
i++;j++;
if(j>=l2)
{
return i-l2+1;
}
}
return -1;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(nxt,0,sizeof nxt);
scanf("%d %d",&l1,&l2);
for(int i=0;i<l1;i++)
{
scanf("%d",&x[i]);
}
for(int i=0;i<l2;i++)
{
scanf("%d",&y[i]);
}
printf("%d\n",kmp());
}
}
相關文章
- HDU 1005 Number Sequence(矩陣快速冪)矩陣
- HDU 6047 Maximum Sequence (貪心)
- HDU 6299-Balanced Sequence(貪心)
- HDU2665 Kth number【主席樹】
- manacher || 擴充套件kmp -- Best Reward HDU - 3613套件KMP
- HDU 3006 The Number of set (狀態壓縮)
- HDU 1394 Minimum Inversion Number (暴力+線段樹)
- HDU5972Regular Number(ShiftAnd演算法 bitset)演算法
- HDU 6274 Master of Sequence(思維+樹狀陣列+二分)AST陣列
- HDU 3397 Sequence operation(線段樹區間染色加區間合併)
- sequence to sequence模型模型
- KMPKMP
- Sequence recognition
- kmp——板子~~~KMP
- KMP模板KMP
- hdu 2111 Saving HDU (DP)
- 專題十六 KMP & 擴充套件KMP & Manacher【Kuangbin】KMP套件
- uvm的sequence
- PostgreSQL 序列(Sequence)SQL
- ORACLE SEQUENCE用法Oracle
- python sequence序列Python
- Rainbow Bracket SequenceAIRacket
- Increasing Sequence with Fixed OR
- PostgreSQL sequence (一)SQL
- 【字串匹配】KMP字串匹配KMP
- KMP&exKMPKMP
- KMP-字串KMP字串
- 論文閱讀:Sequence to sequence learning for joint extraction of entities and relations
- FSM:Sequence 1101 recognizer
- F - Two Sequence Queries
- 裁剪序列Cut the Sequence
- DeepLearning – Overview of Sequence modelView
- E. Block SequenceBloC
- mysql實現sequenceMySql
- LeetCode 444 sequence reconstructionLeetCodeStruct
- JAVA KMP 純模板JavaKMP
- FZU 2275 Game (KMP)GAMKMP
- KMP 自動機KMP