HDU 1711 Number Sequence(KMP)
Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 27986 Accepted Submission(s): 11777
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one
K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N].
The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
Source
KMP,返回第一次出現的地址。只是不是字串而是int陣列而已。
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
int x[1000000+5];
int y[10000+5];
int l1,l2;
int nxt[10000+5];
void kmpnext()
{
int i=0,j=-1;
nxt[0]=-1;
while(i<l2)
{
while(j!=-1&&y[i]!=y[j])
j=nxt[j];
nxt[++i]=++j;
}
}
int kmp()
{
kmpnext();
int i=0,j=0;
while(i<l1)
{
while(j!=-1&&x[i]!=y[j])
j=nxt[j];
i++;j++;
if(j>=l2)
{
return i-l2+1;
}
}
return -1;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(nxt,0,sizeof nxt);
scanf("%d %d",&l1,&l2);
for(int i=0;i<l1;i++)
{
scanf("%d",&x[i]);
}
for(int i=0;i<l2;i++)
{
scanf("%d",&y[i]);
}
printf("%d\n",kmp());
}
}
相關文章
- 【KMP求字串第一個匹配位置】hdu 1711KMP字串
- HDU 1005 Number Sequence(矩陣)矩陣
- HDU4390Number Sequence(容斥原理)
- HDU 1005 Number Sequence(矩陣快速冪)矩陣
- HDU 1005 Number Sequence:矩陣快速冪矩陣
- HDU 2594 (KMP入門)KMP
- HDU 2203(KMP) 親和串KMP
- manacher || 擴充套件kmp -- Best Reward HDU - 3613套件KMP
- 【KMP求字串匹配次數】 hdu 1686KMP字串匹配
- HDU 4668 Finding string (解析字串 + KMP)字串KMP
- HDU5972Regular Number(ShiftAnd演算法 bitset)演算法
- HDU 4937 Lucky Number(列舉進位制)
- HDU4843Wow! Such Sequence!(樹狀陣列寫法)陣列
- hdu 1394 Minimum Inversion Number 【線段樹查詢】
- HDU 6274 Master of Sequence(思維+樹狀陣列+二分)AST陣列
- HDU4675 GCD of Sequence(預處理階乘逆元+推公式)GC公式
- HDU3519Lucky Coins Sequence(DP+矩陣加速)矩陣
- HDU 1394 Minimum Inversion Number (樹狀陣列求逆序數)陣列
- HDU5147 Sequence II(樹狀陣列+字首和+字尾和)陣列
- sequence to sequence模型模型
- oracle 11.2.0.4 sequence之dba_sequences last_number含義測試之一OracleAST
- 【KMP思想求迴圈節】hdu 1358 hust 1010 poj 2406KMP
- HDU3415 Max Sum of Max-K-sub-sequence (DP+單調佇列)佇列
- KMPKMP
- Oracle 11g使用MERGE報錯'ORA-02287..The specified sequence number (CURRVAL'Oracle
- KMP模版KMP
- kmp——板子~~~KMP
- KMP模板KMP
- HDU 2685 I won't tell you this is about number theory (數論 公式 快速冪取模)公式
- ORACLE SEQUENCEOracle
- Sequence recognition
- POJ 3461 kmpKMP
- KMP&exKMPKMP
- 【字串匹配】KMP字串匹配KMP
- 專題十六 KMP & 擴充套件KMP & Manacher【Kuangbin】KMP套件
- KMP Algorithm 字串匹配演算法KMP小結KMPGo字串匹配演算法
- HDU 4055 Number String:字首和優化dp【增長趨勢——處理重複選數】優化
- ORACLE SEQUENCE用法Oracle