HDU 6047 Maximum Sequence (貪心)

Mr_Treeeee發表於2020-04-06

Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 452    Accepted Submission(s): 242


Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1a2n. Just like always, there are some restrictions on an+1a2n: for each number ai, you must choose a number bk from {bi}, and it must satisfy ai≤max{aj-j│bk≤j<i}, and any bk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{2nn+1ai} modulo 109+7 .

Now Steph finds it too hard to solve the problem, please help him.
 

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
 

Output
For each test case, print the answer on one line: max{2nn+1ai} modulo 109+7。
 

Sample Input
4 8 11 8 5 3 1 4 2
 

Sample Output
27
Hint
For the first sample: 1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;
 

Source
 

題意:
給你2個佇列,一個佇列a1到an,另一個b1-bn (1≤b_i≤n)。
讓你再在第一個佇列中新增n個數,新增方式:選一個bi,從a[bi]到a[end](已新增的也算,但是仔細分析其實沒有用),選max(a[i]-i)新增。
求n個數和最大。ps:bi用過了就不能用了。

POINT:
預處理ai=ai-i。算出max陣列,來儲存第i到第n裡面的最大值,可以倒著算出。
那可以對bi佇列從小到大排序,每次使用最前面的bi,可以保證a_n+1是最大的,而且分析可得a_n+1到a_2n是不嚴格單調遞減。
所以每次新增數,只要用max[bi]和a_n+1-(n+1)比較,算出最大值,就是要新增數了,這樣就可以算出答案。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
#define LL long long
const int p = 1e9+7;
const int N = 250000+10;
int a[N];
int b[N];
int Max[N];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        LL ans=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            a[i]-=i;
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&b[i]);
        }
        sort(b+1,b+1+n);
        memset(Max,0,sizeof Max);
        Max[n]=a[n];
        for(int i=n-1;i>=1;i--)
        {
            if(a[i]>Max[i+1])
            {
                Max[i]=a[i];
            }
            else
                Max[i]=Max[i+1];
        }
        int an1;
        int mx=Max[b[1]];
        an1=mx-(n+1);
        (ans+=(LL)mx)%=p;
        for(int i=2;i<=n;i++)
        {
            mx=Max[b[i]];
            mx=max(mx,an1);
            (ans+=(LL)mx)%=p;
        }
        printf("%lld\n",ans);
        
        
    }
}


相關文章