HDU 5821 Ball(貪心)
Ball
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1074 Accepted Submission(s): 645
Problem Description
ZZX has a sequence of boxes numbered 1,2,...,n.
Each box can contain at most one ball.
You are given the initial configuration of the balls. For 1≤i≤n, if the i-th box is empty then a[i]=0, otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.
He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)
He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
You are given the initial configuration of the balls. For 1≤i≤n, if the i-th box is empty then a[i]=0, otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.
He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)
He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
Input
First line contains an integer t. Then t testcases follow.
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].
1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.
0<=a[i],b[i]<=n.
1<=l[i]<=r[i]<=n.
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].
1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.
0<=a[i],b[i]<=n.
1<=l[i]<=r[i]<=n.
Output
For each testcase, print "Yes" or "No" in a line.
Sample Input
5
4 1
0 0 1 1
0 1 1 1
1 4
4 1
0 0 1 1
0 0 2 2
1 4
4 2
1 0 0 0
0 0 0 1
1 3
3 4
4 2
1 0 0 0
0 0 0 1
3 4
1 3
5 2
1 1 2 2 0
2 2 1 1 0
1 3
2 4
Sample Output
No
No
Yes
No
Yes
Author
學軍中學
Source
題意:
經過給出的m次操作,判斷能否從序列1變為序列2。一次操作:從把a到b的球全部拿出來,重新放入a到b個箱子。每個箱子最多隻能放一個球。
POINT:
兩個for迴圈來尋找序列1中的每個元素應該放置到序列2的哪個位置,記錄cnt[]陣列,cnt[i]代表序列1中的第i個箱子應該和序列2中的cnt[i]箱子匹配。每次操作給cnt陣列排序。
這樣就只要看cnt[i]=i,就是匹配成功,要匹配成功就是每個cnt都相等。
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stack>
#include <algorithm>
#include <math.h>
using namespace std;
#define ll long long
const int N = 1010;
int cnt[N];
int a[N],b[N];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n,m;
scanf("%d %d",&n,&m);
for(int i=1;i<=n;i++) scanf("%d",&a[i]);
for(int i=1;i<=n;i++) scanf("%d",&b[i]);
int vis[N];
memset(vis,0,sizeof vis);
int ans=1;
for(int i=1;i<=n;i++)
{
int j;
for(j=1;j<=n;j++)
{
if(a[i]==b[j])
{
if(!vis[j])
{
vis[j]=1;
cnt[i]=j;
break;
}
}
}
if(j==n+1)
{
ans=0;
break;
}
}
while(m--)
{
int a,b;
scanf("%d %d",&a,&b);
sort(cnt+a,cnt+b+1);
}
for(int i=1;i<=n;i++)
{
if(i!=cnt[i])
{
ans=0;
break;
}
}
if(!ans)
{
printf("No\n");
}
else printf("Yes\n");
}
}
相關文章
- HDU 6047 Maximum Sequence (貪心)
- HDU 5813 Elegant Construction (貪心)Struct
- hdu--4435--charge-station+貪心
- HDU 6299-Balanced Sequence(貪心)
- HDU – 4811 – Ball (思維)
- HDU6301 Distinct Values (多校第一場1004) (貪心)
- 貪心
- HDU 1556 Color the ball(線段樹|樹狀陣列)陣列
- 反悔貪心
- Supermarket(貪心)
- 貪心例題
- 貪心+搜尋
- 反悔貪心雜題
- 貪心演算法演算法
- 貪心、構造合集
- 貪心模式記錄模式
- 「貪心」做題記錄
- [反悔貪心] Add One 2
- 貪心 做題筆記筆記
- 7.5 - 貪心篇完結
- 貪心演算法Dijkstra演算法
- 24/03/20 貪心(一)
- 漲薪【貪心】【快速冪】
- Leetcode 貪心:差值調整LeetCode
- Least Cost Bracket Sequence(貪心)ASTRacket
- 刪數問題(貪心)
- 牛客 tokitsukaze and Soldier 貪心
- 貪心-刪數問題
- 貪心-*活動選擇
- 學一下貪心演算法-學一下貪心演算法演算法
- HDU - 6003 Problem Buyer題解(貪心選擇演算法,鴿巢原理,優先佇列維護)演算法佇列
- 貪心演算法(貪婪演算法,greedy algorithm)演算法Go
- 9-貪心演算法演算法
- 【貪心】POJ 3617:Best Cow Line
- Moving Tables(貪心演算法)演算法
- 淺談貪心與動歸
- 牛客 切長條(貪心)
- 1413D. Shurikens(貪心,棧)3D