HDU 5813 Elegant Construction (貪心)
Elegant Construction
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1034 Accepted Submission(s): 543
Special Judge
Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.
For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.
Your task is constructing such a city. Now it's your showtime!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.
For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.
Your task is constructing such a city. Now it's your showtime!
Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.
Output
For each test case, output "Case #X: Y" in a line (without quotes), where X is the case number starting from 1, and Y is "Yes" if you can construct successfully or "No" if it's impossible to reach the requirements.
If Y is "Yes", output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.
If Y is "Yes", output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.
Sample Input
3
3
2 1 0
2
1 1
4
3 1 1 0
Sample Output
Case #1: Yes
2
1 2
2 3
Case #2: No
Case #3: Yes
4
1 2
1 3
2 4
3 4
Author
SYSU
Source
題意:有向圖,給你n個頂點,設定每個頂點應該連線幾個,求出接連的方案,邊數沒有要求。
POINT:
既然邊數沒有要求,就從要求少的排序,每次都往最前面開始連,雖然這樣邊是最多的。但也是最簡單的。
當時沒有過也是題意看不完全的原因。
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <queue>
#include <algorithm>
#include <math.h>
using namespace std;
struct node
{
int num;
int i;
}a[1010];
bool cmd(node a,node b)
{
return a.num<b.num;
}
int mp[1010][1010];
int main()
{
int T;
scanf("%d",&T);
int p=0;
while(T--)
{
int n;
scanf("%d",&n);
memset(mp,0,sizeof mp);
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i].num);
a[i].i=i;
}
sort(a+1,a+1+n,cmd);
int flag=1;
int ans=0;
for(int i=1;i<=n;i++)
{
if(a[i].num>=i)
{
flag=0;
break;
}
else
{
for(int j=1;j<=a[i].num;j++)
{
mp[a[i].i][a[j].i]=1;
}
ans+=a[i].num;
}
}
if(flag)
{
printf("Case #%d: Yes\n%d\n",++p,ans);
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(mp[i][j]) printf("%d %d\n",i,j);
}
}
}
else
printf("Case #%d: No\n",++p);
}
}
相關文章
- HDU 4550卡片遊戲(貪心)遊戲
- hdu4268 multiset應用 貪心
- hdu5380 貪心+雙端佇列佇列
- hdu 3177Crixalis's Equipment(貪心)UI
- hdu 1789 Doing Homework again(簡單貪心)AI
- hdu4313 貪心並查集 || 樹形dp並查集
- HDU5630 Hiking(貪心+優先佇列)佇列
- 貪心
- HDU 4252A Famous City(弱資料可以使用貪心)
- HDU 5303 Delicious Apples (貪心 列舉 好題)APP
- 反悔貪心
- Supermarket(貪心)
- HDU 5135 Little Zu Chongzhi's Triangles(狀壓dp或者貪心)
- 貪心模式記錄模式
- 貪心、構造合集
- 貪心演算法演算法
- 反悔貪心雜題
- UVA11292 HDU1902 POJ3646 The Dragon of Loowater【貪心】Go
- Least Cost Bracket Sequence(貪心)ASTRacket
- 牛客 tokitsukaze and Soldier 貪心
- 24/03/20 貪心(一)
- 7.5 - 貪心篇完結
- 貪心 做題筆記筆記
- 「貪心」做題記錄
- 學一下貪心演算法-學一下貪心演算法演算法
- 貪心演算法(貪婪演算法,greedy algorithm)演算法Go
- 淺談貪心與動歸
- 貪心演算法Dijkstra演算法
- 貪心(入門簡單題)
- 9-貪心演算法演算法
- [反悔貪心] Add One 2
- hdu5289||2015多校聯合第一場1002貪心+RMQMQ
- HDU - 6003 Problem Buyer題解(貪心選擇演算法,鴿巢原理,優先佇列維護)演算法佇列
- 程式猿生存指南-63 貪心姑娘
- 演算法基礎–貪心策略演算法
- Moving Tables(貪心演算法)演算法
- 1413D. Shurikens(貪心,棧)3D
- Leetcode 貪心:差值調整LeetCode