HDU 5813 Elegant Construction (貪心)

Mr_Treeeee發表於2020-04-06


Elegant Construction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1034    Accepted Submission(s): 543
Special Judge


Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it's your showtime!
 

Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.
 

Output
For each test case, output "Case #X: Y" in a line (without quotes), where X is the case number starting from 1, and Y is "Yes" if you can construct successfully or "No" if it's impossible to reach the requirements.

If Y is "Yes", output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.
 

Sample Input
3 3 2 1 0 2 1 1 4 3 1 1 0
 

Sample Output
Case #1: Yes 2 1 2 2 3 Case #2: No Case #3: Yes 4 1 2 1 3 2 4 3 4
 

Author
SYSU
 

Source
 

題意:有向圖,給你n個頂點,設定每個頂點應該連線幾個,求出接連的方案,邊數沒有要求。

POINT:

既然邊數沒有要求,就從要求少的排序,每次都往最前面開始連,雖然這樣邊是最多的。但也是最簡單的。

當時沒有過也是題意看不完全的原因。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <queue>
#include <algorithm>
#include <math.h>
using namespace std;
struct node
{
    int num;
    int i;
}a[1010];
bool cmd(node a,node b)
{
    return a.num<b.num;
}
int mp[1010][1010];
int main()
{
    int T;
    scanf("%d",&T);
    int p=0;
    while(T--)
    {
        int n;
        scanf("%d",&n);
        memset(mp,0,sizeof mp);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i].num);
            a[i].i=i;
        }
        sort(a+1,a+1+n,cmd);
        int flag=1;
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            if(a[i].num>=i)
            {
                flag=0;
                break;
            }
            else
            {
                for(int j=1;j<=a[i].num;j++)
                {
                    mp[a[i].i][a[j].i]=1;
                }
                ans+=a[i].num;
            }
        }
        if(flag)
        {
            printf("Case #%d: Yes\n%d\n",++p,ans);
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    if(mp[i][j]) printf("%d %d\n",i,j);
                }
            }
            
        }
        else
            printf("Case #%d: No\n",++p);
    }
}



相關文章