HDU 6298 Maximum Multiple(找規律)

大白QQly成長日記發表於2018-08-27

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

Sample Input


 

3

1

2

3

Sample Output


 

-1

-1

1

題目大意:給出一個n,求a,b,c要求n能夠整除a,b,c且a+b+c=n,輸出a*b*c最大的情況。

思路:這道題讓我學會了一個技巧,遇事不決先打表(Get√)。

打表如圖:然後發現,能出解的情況只有能被3.4整除的數,當能被3整除時,abc相等,當能被4整除且不被3整除時a=2b=2c。

程式碼如下:

#include<set>
#include<map>
#include<list>
#include<deque>
#include<cmath>
#include<queue>
#include<string>
#include<vector>
#include<stdio.h>
#include<sstream>
#include<stdlib.h>
#include<string.h>
#include<ext/rope>
#include<iostream>
#include<algorithm>
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
#define per(i,a,b) for(int i=a;i<=b;++i)
#define max(a,b)  a>b?a:b
#define min(a,b)  a<b?a:b
#define LL long long 
//#define swap(a,b) {int t=a;a=b;b=t} 
using namespace std;
using namespace __gnu_cxx;
int main()
{
    long long int n,t,i,j,maxn=0;;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld",&n);
        if(n%3==0&&n>2)
        {
            printf("%lld\n",(n/3)*(n/3)*(n/3));
        }
        else if(n%4==0&&n>2)
        {
            printf("%lld\n",(n/4)*(n/4)*(n/4)*2);
        }
        else printf("-1\n");       
    }
    return 0; 
}

 

相關文章