HDU 6298 Maximum Multiple(找規律)
Problem Description
Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.
Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).
Output
For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.
Sample Input
3
1
2
3
Sample Output
-1
-1
1
題目大意:給出一個n,求a,b,c要求n能夠整除a,b,c且a+b+c=n,輸出a*b*c最大的情況。
思路:這道題讓我學會了一個技巧,遇事不決先打表(Get√)。
打表如圖:然後發現,能出解的情況只有能被3.4整除的數,當能被3整除時,abc相等,當能被4整除且不被3整除時a=2b=2c。
程式碼如下:
#include<set>
#include<map>
#include<list>
#include<deque>
#include<cmath>
#include<queue>
#include<string>
#include<vector>
#include<stdio.h>
#include<sstream>
#include<stdlib.h>
#include<string.h>
#include<ext/rope>
#include<iostream>
#include<algorithm>
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
#define per(i,a,b) for(int i=a;i<=b;++i)
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define LL long long
//#define swap(a,b) {int t=a;a=b;b=t}
using namespace std;
using namespace __gnu_cxx;
int main()
{
long long int n,t,i,j,maxn=0;;
scanf("%lld",&t);
while(t--)
{
scanf("%lld",&n);
if(n%3==0&&n>2)
{
printf("%lld\n",(n/3)*(n/3)*(n/3));
}
else if(n%4==0&&n>2)
{
printf("%lld\n",(n/4)*(n/4)*(n/4)*2);
}
else printf("-1\n");
}
return 0;
}
相關文章
- HDU-6415 Rikka with Nash Equilibrium (DP/找規律)UI
- HDU 5795 A Simple Nim (SG函式+打表找規律)函式
- HDU 6415(dp/找規律-2018多校第九場1001)
- 打表找規律
- HDU 2197 本原串 (規律+快速冪)
- HUNAN -11566 Graduation Examination(找規律)NaN
- HDU 6047 Maximum Sequence (貪心)
- LeetCode-6. Z字形變換(找規律)LeetCode
- Touring cities (找規律 哈密爾頓迴路)
- Gym - 101532A Subarrays Beauty(位操作找規律)
- ZOJ Monthly, January 2019 - A Little Sub and Pascal's Triangle(找規律)
- HDU 1792 - A New Change Problem(規律,最大不能組合數及其個數)
- QOJ7789-一道位運算找規律好題
- 【LeetCode動態規劃#04】不同的二叉搜尋樹(找規律,有點像智力題)LeetCode動態規劃
- leedcode-單詞規律
- 三、凸透鏡成像規律
- LeetCode-單詞規律LeetCode
- LeetCode-290-單詞規律LeetCode
- 快三長龍有規律嗎?
- Java欄位初始化規律Java
- 如何探索事物的客觀規律?
- 圖片跨域規律探尋跨域
- python3 中 and 和 or 運算規律Python
- ●連續質數2.3.5.7.11.13.17.19的規律●(9)
- ●連續質數2.3.5.7.11.13.17.19的規律●(6)
- ●連續質數2.3.5.7.11.13.17.19的規律●(5)
- ●連續質數2.3.5.7.11.13.17.19的規律●(4)
- ●連續質數2.3.5.7.11.13.17.19的規律●(3)
- ●連續質數2.3.5.7.11.13.17.19的規律●(10)
- ●連續質數2.3.5.7.11.13.17.19的規律●(1)
- ●連續質數2.3.5.7.11.13.17.19的規律●(2)
- ●連續質數2.3.5.7.11.13.17.19的規律●(15)
- ●連續質數2.3.5.7.11.13.17.19的規律●(16)
- ●連續質數2.3.5.7.11.13.17.19的規律●(11)
- ●連續質數2.3.5.7.11.13.17.19的規律●(13)
- ●連續質數2.3.5.7.11.13.17.19的規律●(8)
- ●連續質數2.3.5.7.11.13.17.19的規律●(7)
- ●連續質數2.3.5.7.11.13.17.19的規律●(12)