HDU 6298 Maximum Multiple(找規律)
Problem Description
Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.
Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).
Output
For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.
Sample Input
3
1
2
3
Sample Output
-1
-1
1
題目大意:給出一個n,求a,b,c要求n能夠整除a,b,c且a+b+c=n,輸出a*b*c最大的情況。
思路:這道題讓我學會了一個技巧,遇事不決先打表(Get√)。
打表如圖:然後發現,能出解的情況只有能被3.4整除的數,當能被3整除時,abc相等,當能被4整除且不被3整除時a=2b=2c。
程式碼如下:
#include<set>
#include<map>
#include<list>
#include<deque>
#include<cmath>
#include<queue>
#include<string>
#include<vector>
#include<stdio.h>
#include<sstream>
#include<stdlib.h>
#include<string.h>
#include<ext/rope>
#include<iostream>
#include<algorithm>
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
#define per(i,a,b) for(int i=a;i<=b;++i)
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define LL long long
//#define swap(a,b) {int t=a;a=b;b=t}
using namespace std;
using namespace __gnu_cxx;
int main()
{
long long int n,t,i,j,maxn=0;;
scanf("%lld",&t);
while(t--)
{
scanf("%lld",&n);
if(n%3==0&&n>2)
{
printf("%lld\n",(n/3)*(n/3)*(n/3));
}
else if(n%4==0&&n>2)
{
printf("%lld\n",(n/4)*(n/4)*(n/4)*2);
}
else printf("-1\n");
}
return 0;
}
相關文章
- HDU 4951 Multiplication table(找規律)
- HDU5139 Formula (找規律+離線處理)ORM
- HDU 5795 A Simple Nim (SG函式+打表找規律)函式
- HDU-6415 Rikka with Nash Equilibrium (DP/找規律)UI
- HDU 5439 Aggregated Counting(找規律+預處理)
- 打表找規律
- HDU 2897-邂逅明下(博弈-SG函式打表找規律)函式
- HDU 1847 Good Luck in CET-4 Everybody!(找規律版巴什博奕)Go
- HDU 1847-Good Luck in CET-4 Everybody!(博弈-SG函式/找規律)Go函式
- HDU4342 History repeat itself數學規律題
- Touring cities (找規律 哈密爾頓迴路)
- 數學規律題,數論知識:hdu1792
- LeetCode-6. Z字形變換(找規律)LeetCode
- codeforces 340CTourist Problem(找規律數學題)
- HUNAN -11566 Graduation Examination(找規律)NaN
- Gym - 101532A Subarrays Beauty(位操作找規律)
- 【組合數+找規律】codeforces 815B - Karen and Test
- QOJ7789-一道位運算找規律好題
- HDU 1792 - A New Change Problem(規律,最大不能組合數及其個數)
- HDU 3682To Be an Dream Architect(統計規律題目 三線相交bug)
- HDU 2028 Lowest Common Multiple Plus
- HDU 4002Find the maximum(尤拉函式)函式
- ZOJ Monthly, January 2019 - A Little Sub and Pascal's Triangle(找規律)
- EMS單號規律與順豐單號規律(C#)C#
- A Multiplication Game (博弈,規律)GAM
- 【LeetCode動態規劃#04】不同的二叉搜尋樹(找規律,有點像智力題)LeetCode動態規劃
- leedcode-單詞規律
- 圖片跨域規律探尋跨域
- LeetCode-單詞規律LeetCode
- 索引的應用規律總結索引
- Java欄位初始化規律Java
- 山東省第四屆ACM大學生程式設計競賽-Alice and Bob(二進位制&&找規律)ACM程式設計
- 軟體開發的21條規律
- LeetCode-290-單詞規律LeetCode
- votedisk在ASM diskgroup上的存放規律ASM
- Python裡的引用與拷貝規律Python
- python3 中 and 和 or 運算規律Python
- 事理圖譜:事件演化的規律和模式事件模式