HDU 1792 - A New Change Problem(規律,最大不能組合數及其個數)
A New Change Problem
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1628 Accepted Submission(s): 1041
Problem Description
Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.
Input
The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line.
Output
For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.
Sample Input
2 3
3 4
Sample Output
1 1
5 3
給出 a,b(且a,b互質) 。求解 ax + by 不能表示的最大數字以及不能表示的數字的個數。
最大不能表示:n*m-n-m
所有不能表示的個數:(m-1)*(n-1)/2
詳細證明 :http://blog.sina.com.cn/s/blog_79b832820100riqp.html
#include <bits/stdc++.h>
using namespace std;
#define clr(a) memset(a,0,sizeof(a))
#define ling cout<<"-----------------"<<endl;
typedef long long ll;
const int maxn = 1e5+10;
const int MAXN = 1e6+10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9+7;
const int N = 1010;
int main(){
int a,b;
while(~scanf("%d %d",&a,&b)){
printf("%d %d\n",a*b-a-b,(a-1)*(b-1)/2);
}
return 0;
}
相關文章
- hdu 1792 A New Change Problem(數論)
- HDU 1792-A New Change Problem(互質數的最大不能表示數)
- HDU 2662 Coin && HDU 1792 A New Change Problem (互質數最大不能生成數)
- 類最大hdu 1792 A New Change Problem
- 【HDU - 1792】A New Change Problem(推公式、互質數的最大不能表示數)公式
- HDU 1792 A New Change Problem
- Hdu 1792 A New Change Problem 結論
- hdu 1792 A New Change Problem 剩餘系
- 數學規律題,數論知識:hdu1792
- codeforces 340CTourist Problem(找規律數學題)
- HDU4342 History repeat itself數學規律題
- 【組合數+找規律】codeforces 815B - Karen and Test
- HDU 4497 GCD and LCM(拆素數+組合)GC
- HDU 2582 f(n) (組合數的gcd)GC
- HDU1792(公式)公式
- 【數學】組合數學 - 排列組合
- HDU 6298 Maximum Multiple(找規律)
- HDU 4951 Multiplication table(找規律)
- 大小寫字母和數字的組合,不能使用特殊字元正規表示式字元
- 動態規劃-硬幣組合數目動態規劃
- hdu 4546 優先佇列 數列組合和第m小佇列
- 組合數學
- 【數學】組合數學 - 卡特蘭數
- 組合數問題
- lg組合計數
- 組合數字首和
- 組合數學筆記-排列與組合筆記
- 組合數學筆記-特殊計數數列筆記
- 【組合數學】組合數學簡介 ( 組合思想 2 : 數學歸納法 | 數學歸納法推廣 | 多重歸納思想 )
- 單機最大的TCP連線數及其修改TCP
- HDU5139 Formula (找規律+離線處理)ORM
- Python引數組合Python
- 《小 學 組 合 數 學》
- Training - Problem and Change ManagementAI
- 機器學習之特徵組合: 多非線性規律進行編碼機器學習特徵
- 求:1,2,5這三個數不同組合的和為100的組合的個數!Java實現。Java
- 求陣列中k個數的所有組合陣列
- C#--求三個數的最大數C#