HDU 1792 - A New Change Problem(規律,最大不能組合數及其個數)
A New Change Problem
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1628 Accepted Submission(s): 1041
Problem Description
Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.
Input
The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line.
Output
For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.
Sample Input
2 3
3 4
Sample Output
1 1
5 3
給出 a,b(且a,b互質) 。求解 ax + by 不能表示的最大數字以及不能表示的數字的個數。
最大不能表示:n*m-n-m
所有不能表示的個數:(m-1)*(n-1)/2
詳細證明 :http://blog.sina.com.cn/s/blog_79b832820100riqp.html
#include <bits/stdc++.h>
using namespace std;
#define clr(a) memset(a,0,sizeof(a))
#define ling cout<<"-----------------"<<endl;
typedef long long ll;
const int maxn = 1e5+10;
const int MAXN = 1e6+10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9+7;
const int N = 1010;
int main(){
int a,b;
while(~scanf("%d %d",&a,&b)){
printf("%d %d\n",a*b-a-b,(a-1)*(b-1)/2);
}
return 0;
}
相關文章
- 【HDU - 1792】A New Change Problem(推公式、互質數的最大不能表示數)公式
- HDU 1792 A New Change Problem
- Hdu 1792 A New Change Problem 結論
- HDU-1792-( 兩個互質的數線性組合最大不能表示的數和不能表示數的個數)
- PAT-B 1056 組合數的和【規律】
- hdu 5698 瞬間移動 【質因數分解求組合數】
- HDU 2068 RPG的錯排 (錯排+組合數)
- HDU 6298 Maximum Multiple(找規律)
- HDU 2197 本原串 (規律+快速冪)
- 【數學】組合數學 - 排列組合
- 【dp+組合數學】hdu 2018 多校第九場 1001 Rikka with Nash Equilibrium hdu 6415UI
- HDU - 6182 A Math Problem
- change ^M to new line
- HDU-6415 Rikka with Nash Equilibrium (DP/找規律)UI
- HDU 1002 A + B Problem II
- ●連續質數2.3.5.7.11.13.17.19的規律●(9)
- ●連續質數2.3.5.7.11.13.17.19的規律●(6)
- ●連續質數2.3.5.7.11.13.17.19的規律●(5)
- ●連續質數2.3.5.7.11.13.17.19的規律●(4)
- ●連續質數2.3.5.7.11.13.17.19的規律●(3)
- ●連續質數2.3.5.7.11.13.17.19的規律●(10)
- ●連續質數2.3.5.7.11.13.17.19的規律●(1)
- ●連續質數2.3.5.7.11.13.17.19的規律●(2)
- ●連續質數2.3.5.7.11.13.17.19的規律●(15)
- ●連續質數2.3.5.7.11.13.17.19的規律●(16)
- ●連續質數2.3.5.7.11.13.17.19的規律●(11)
- ●連續質數2.3.5.7.11.13.17.19的規律●(13)
- ●連續質數2.3.5.7.11.13.17.19的規律●(8)
- ●連續質數2.3.5.7.11.13.17.19的規律●(7)
- ●連續質數2.3.5.7.11.13.17.19的規律●(12)
- ●連續質數2.3.5.7.11.13.17.19的規律●(14)
- 組合數學
- 【數學】組合數學 - 卡特蘭數
- 12345這五個數,列印出它所有的組合。4不能在中間,3和5不能挨著
- hdu 3879 Base Station (最大權 閉合圖)
- 投資市場上不能不知的三個規律
- HDU 5795 A Simple Nim (SG函式+打表找規律)函式
- 組合數問題