【HDU - 1792】A New Change Problem(推公式、互質數的最大不能表示數)
Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.
Input
The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line.
Output
For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.
Sample Input
2 3
3 4
Sample Output
1 1
5 3
題意:
給定兩個互質的數 a ,b ,求不限數量個 a 和 b 組成的數中最大不能表示的數,和不能表示的數的個數。
思路:(給出證明過程的部落格)
看了別人的部落格,才知道能推出公式。最大不能表示的數是 (a-1)*b-a,個數是 (a-1) * (b-1) / 2。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
int main()
{
ll a,b;
while(~scanf("%lld%lld",&a,&b))
{
printf("%lld %lld\n",(a-1)*b-a,(a-1)*(b-1)/2);
}
return 0;
}
這兩個部落格也給出了證明:
相關文章
- HDU 1792-A New Change Problem(互質數的最大不能表示數)
- HDU 2662 Coin && HDU 1792 A New Change Problem (互質數最大不能生成數)
- hdu 1792 A New Change Problem(數論)
- 類最大hdu 1792 A New Change Problem
- HDU 1792 - A New Change Problem(規律,最大不能組合數及其個數)
- HDU 1792 A New Change Problem
- Hdu 1792 A New Change Problem 結論
- hdu 1792 A New Change Problem 剩餘系
- HDU1792(公式)公式
- 數學規律題,數論知識:hdu1792
- HDU 1299 Diophantus of Alexandria (公式變形 分解質因數)公式
- 求最大質因數
- 四元數的旋轉公式推導公式
- HDU 4686 (推公式+矩陣快速冪)公式矩陣
- 四元數旋轉公式推導公式
- 【質數判斷】給定兩個數,判斷這兩個數是否互質?
- Training - Problem and Change ManagementAI
- CCF NOI 1028 判斷互質 :利用歐幾里得演算法最大公因數演算法
- 數學公式公式
- change ^M to new line
- MySQL單表最大記錄數不能超過多少?MySql
- HDU5293 : Tree chain problemAI
- 有趣的數學公式(一)公式
- HDU 4135 Co-prime(容斥原理+分解質因數)
- HDU4675 GCD of Sequence(預處理階乘逆元+推公式)GC公式
- LightOJ 1070 Algebraic Problem:矩陣快速冪 + 數學推導AI矩陣
- 質數判斷、質因子分解、質數篩
- 更改 Excel 迭代公式的次數Excel公式
- C#--求三個數的最大數C#
- Excel提取數字公式Excel公式
- 質數與約數
- hdu5435 數位dp(大數的處理)
- HDU 2685 I won't tell you this is about number theory (數論 公式 快速冪取模)公式
- Jboss的最大連線數
- 小於n的最大數
- 如何求數列的通項公式公式
- 定義陣列時為什麼不能用含有變數的表示式陣列變數
- 計算總頁數公式公式