【HDU - 1792】A New Change Problem(推公式、互質數的最大不能表示數)
Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.
Input
The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line.
Output
For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.
Sample Input
2 3
3 4
Sample Output
1 1
5 3
題意:
給定兩個互質的數 a ,b ,求不限數量個 a 和 b 組成的數中最大不能表示的數,和不能表示的數的個數。
思路:(給出證明過程的部落格)
看了別人的部落格,才知道能推出公式。最大不能表示的數是 (a-1)*b-a,個數是 (a-1) * (b-1) / 2。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
int main()
{
ll a,b;
while(~scanf("%lld%lld",&a,&b))
{
printf("%lld %lld\n",(a-1)*b-a,(a-1)*(b-1)/2);
}
return 0;
}
這兩個部落格也給出了證明:
相關文章
- HDU 1792 - A New Change Problem(規律,最大不能組合數及其個數)
- HDU 1792 A New Change Problem
- Hdu 1792 A New Change Problem 結論
- HDU-1792-( 兩個互質的數線性組合最大不能表示的數和不能表示數的個數)
- 求最大質因數
- 四元數的旋轉公式推導公式
- HDU - 6182 A Math Problem
- change ^M to new line
- 四元數旋轉公式推導公式
- HDU 1002 A + B Problem II
- hdu 5698 瞬間移動 【質因數分解求組合數】
- 【hdu】口算訓練/二分/質因數分解
- 【質數判斷】給定兩個數,判斷這兩個數是否互質?
- HDU 4135 Co-prime(容斥原理+分解質因數)
- MySQL單表最大記錄數不能超過多少?MySql
- 數學公式公式
- CCF NOI 1028 判斷互質 :利用歐幾里得演算法最大公因數演算法
- 有趣的數學公式(一)公式
- HDU 6415 (計數dp)
- hdu2084數塔
- 求最大公約數 & 最大公約數
- Problem L: 第二大的數
- HDU 2256Problem of Precision(矩陣快速冪)矩陣
- Excel提取數字公式Excel公式
- 質數判斷、質因子分解、質數篩
- 551. Preparing Problem(思維+數學)
- 小於n的最大數
- hdu1297大數遞迴遞迴
- HDU 6033 Add More Zero (數學)
- 數論——質數與約數
- 質數與約數
- 三數取中公式思路公式
- §3. 復變數的指數函式·尤拉公式變數函式公式
- 最大數問題
- 科技愛好者週刊(第 324 期):人類已知的最大質數
- 【公式與引數】用友U8-UFO報表公式與引數基礎公式
- Problem:三角形計數
- 【數值框架】戰鬥公式:傷害公式選擇框架公式