Problem L: 第二大的數

停雲喵喵喵發表於2020-12-28

Description
輸入15個整數,輸出其中第二大的數。
Input
輸入15個整數。資料保證至少有兩個不同的數字。
Output
輸出其中與最大值不同的第二大的數。
Sample Input
1 22 31 6 15 25 6 14 1 15 97 3 20 0 44
Sample Output
44

#include<stdio.h>
#include<limits.h>
int main()
{
    int i;
    int a[15];
    scanf("%d",&a[0]);
    int max = a[0];
    int sec = -INT_MAX;
    for(i=1;i<15;i++)
    {
        scanf("%d",&a[i]);
        if(a[i]>max)
        {
            sec=max;max=a[i];
        }
        else if(a[i]>sec&&a[i]!=max)
            sec=a[i];
    }
    printf("%d",sec);
}

相關文章