Problem L: 第二大的數
Description
輸入15個整數,輸出其中第二大的數。
Input
輸入15個整數。資料保證至少有兩個不同的數字。
Output
輸出其中與最大值不同的第二大的數。
Sample Input
1 22 31 6 15 25 6 14 1 15 97 3 20 0 44
Sample Output
44
#include<stdio.h>
#include<limits.h>
int main()
{
int i;
int a[15];
scanf("%d",&a[0]);
int max = a[0];
int sec = -INT_MAX;
for(i=1;i<15;i++)
{
scanf("%d",&a[i]);
if(a[i]>max)
{
sec=max;max=a[i];
}
else if(a[i]>sec&&a[i]!=max)
sec=a[i];
}
printf("%d",sec);
}
相關文章
- 第二大的數
- 551. Preparing Problem(思維+數學)
- L0、L1與L2範數各自功能
- Problem:三角形計數
- 機器學習中的範數規則化之(一)L0、L1與L2範數機器學習
- 【HDU - 1792】A New Change Problem(推公式、互質數的最大不能表示數)公式
- Assignment Problem的若干思考
- Mathematical Problem
- Sum Problem
- Problem E: 向量的刪除
- L1-089 最好的文件 分數 5
- 機器學習中的範數規則化-L0,L1和L2正規化機器學習
- Yet Another Problem
- Nanami and the Constructive ProblemNaNStruct
- Prime Ring Problem
- 2019 MCM Problem A
- L1-056 猜數字 分數 20
- hduoj1002 A + B Problem II (大數相加 字串模擬)字串
- 【WA】【編碼】數數字-BSG白山極客挑戰賽Problem A-2016.05.20
- HDU 1792 - A New Change Problem(規律,最大不能組合數及其個數)
- L2-006 樹的遍歷 分數 25
- linux科研武器庫 - 檔案數量統計 - ls -l | grep "^-" | wc -lLinux
- L1-028 判斷素數 分數 10
- L2-024 部落 分數 25
- L1-027 出租 分數 20
- L1-009 N個數求和
- E. Not a Nim Problem
- Nanami and the House Protecting ProblemNaN
- HDU - 6182 A Math Problem
- Problem A. Ascending Rating
- Fixed "There was a problem with the editor 'vi'"
- Prime Ring Problem (dfs)
- 機器學習中正則懲罰項L0/L1/L2範數詳解機器學習
- L1-088 靜靜的推薦 分數 20
- L1-080 乘法口訣數列 分數 20
- L1-025 正整數A+B 分數 15
- L1-054 福到了 分數 15
- L1-022 奇偶分家 分數 10