Sum Problem

太陽湖散步發表於2020-11-16

做題地址:http://acm.hdu.edu.cn/showproblem.php?pid=1001


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050


這一題,額,,,,
公式:
1 + 2 + 3 + … + n = n * (n - 1) / 2


下面是程式碼

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm> 

using namespace std;

int main() {
	long long n; 
	while (~scanf("%lld", &n)) {
		printf("%lld\n\n", n * (n + 1) / 2);
	}
	
	return 0;
}