Prime Ring Problem (dfs)
Prime Ring Problem
Time Limit: 2000/1000ms (Java/Others)
Problem Description:
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. Note: the number of first circle should always be 1.
Input:
n (0 < n < 20).
Output:
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. You are to write a program that completes above process. Print a blank line after each case even if there is no answer.
Sample Input:
6 8
Sample Output:
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
總算能靠自己AC一道DFS題目了,雖然期間bug無數,改了又改,以下是程式碼:
#include<bits/stdc++.h>
#define ll long long
using namespace std;
int a[30];
int x = 1;
int n;
int save[30];
void dfs(int pre,int s)
{
if(s == n+1)
{
if(pre+1==3||pre+1==5||pre+1==7||pre+1==11||pre+1==13||pre+1==17||pre+1==19||pre+1==23||pre+1==29||pre+1==31||pre+1==37)
{
for(int i = 1;i < n;i++)
printf("%d ",save[i]);
printf("%d\n",save[n]);
}
return ;
}
for(int i = 2;i <= n;i++)
{
if(!a[i]&&(i+pre==3||i+pre==5||i+pre==7||i+pre==11||i+pre==13||i+pre==17|pre+i==19||pre+i==23||pre+i==29||pre+i==31||pre+i==37))
{
a[i] = 1;
save[s] = i;
dfs(i,s+1);
a[i] = 0;
}
else if(i == n)
return ;
}
}
int main()
{
while(scanf("%d",&n) != EOF)
{
printf("Case %d:\n",x++);
save[1] = 1;
if(n != 19)
dfs(1,2);
printf("\n");
}
return 0;
}
相關文章
- Prime Ring Problem
- Prime Video for Mac Prime影片播放器IDEMac播放器
- BZOJ3457 : Ring
- Prime影片下載:Kigo Amazon Prime Video Downloader for MacGoIDEMac
- DFS
- [vulnhub]Prime1
- Mathematical Problem
- Sum Problem
- POJ3126-Prime Path
- C++ Prime 學習C++
- The House of Mind (FASTBIN METHOD) PRIMEAST
- dfs序
- DFS樹
- dfs技巧
- Prime影片播放器Clicker for Prime Video,擁有更好的觀看體驗播放器IDE
- Yet Another Problem
- Nanami and the Constructive ProblemNaNStruct
- 2019 MCM Problem A
- 戳戳HackShield Ring0反除錯除錯
- 深搜dfs
- Tempter of the Bone(DFS)
- E. Not a Nim Problem
- Nanami and the House Protecting ProblemNaN
- HDU - 6182 A Math Problem
- Problem A. Ascending Rating
- Fixed "There was a problem with the editor 'vi'"
- Improving the speed of the Miller-Rabin Prime Test
- DAG bfs + dfs 126,
- 樹的DFS序
- P1865 A % B Problem
- Assignment Problem的若干思考
- A + B Problem II hd 1002
- Joe Harris is a real problem with this team
- Follow/Unfollow problem in system design
- Euclid Problem - PC110703
- HDU 1002 A + B Problem II
- POJ 2355 Railway Ticket problemAI
- The Door Problem 並查集並查集