Prime Ring Problem (dfs)

Tiny_W發表於2018-03-14

Prime Ring Problem

Time Limit: 2000/1000ms (Java/Others)

Problem Description:

         A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1.

Input:

n (0 < n < 20). 

Output:

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case even if there is no answer.

Sample Input:

6
8

Sample Output:

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2



總算能靠自己AC一道DFS題目了,雖然期間bug無數,改了又改,以下是程式碼:

#include<bits/stdc++.h>
#define ll long long
using namespace std;
int a[30];
int x = 1;
int n;
int save[30];
void dfs(int pre,int s)
{
    if(s == n+1)
    {
        if(pre+1==3||pre+1==5||pre+1==7||pre+1==11||pre+1==13||pre+1==17||pre+1==19||pre+1==23||pre+1==29||pre+1==31||pre+1==37)
        {
            for(int i = 1;i < n;i++)
                printf("%d ",save[i]);
            printf("%d\n",save[n]);
        }
        return ;
    }
    for(int i = 2;i <= n;i++)
    {
        if(!a[i]&&(i+pre==3||i+pre==5||i+pre==7||i+pre==11||i+pre==13||i+pre==17|pre+i==19||pre+i==23||pre+i==29||pre+i==31||pre+i==37))
        {
                a[i] = 1;
                save[s] = i;
                dfs(i,s+1);
                a[i] = 0;
        }
        else if(i == n)
            return ;
    }
}
int main()
{
    while(scanf("%d",&n) != EOF)
    {
        printf("Case %d:\n",x++);
        save[1] = 1;
        if(n != 19)
            dfs(1,2);
        printf("\n");
    }
    return 0;
}