Prime Ring Problem
Prime Ring Problem
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
#include<iostream>
#include<cstring>
using namespace std;
#define N 15
int n,ant = 0;
int a[N]={0},vis[N]={0};
int isPrime(int n){
int ans = 0;
for(int i =2; i < n; i++){
if(n % i == 0){
ans++;
break;
}
}
return ans;
}
void dfs(int pre,int dep){
if(dep>=n && !isPrime(a[0] + a[n-1])){
for(int i = 0; i < n-1; i++ ){
cout<<a[i]<<" ";
}
cout<<a[n-1]<<endl;
return;
}
for(int i = 1; i < n; i++ ){
if(vis[i]==0 && (dep==0 || !isPrime(a[pre]+i+1))){
vis[i]=1;
a[dep]=i+1;
dfs(pre+1,dep+1);
vis[i] = 0;
}
}
}
int main(){
int num = 0;
while(cin>>n){
a[0] = 1;
printf("Case %d:\n",++num);
dfs(0,1);
printf("\n");
}
return 0;
}
相關文章
- Prime Ring Problem (dfs)
- Prime Video for Mac Prime影片播放器IDEMac播放器
- BZOJ3457 : Ring
- Prime影片下載:Kigo Amazon Prime Video Downloader for MacGoIDEMac
- [vulnhub]Prime1
- Mathematical Problem
- Sum Problem
- POJ3126-Prime Path
- C++ Prime 學習C++
- The House of Mind (FASTBIN METHOD) PRIMEAST
- Prime影片播放器Clicker for Prime Video,擁有更好的觀看體驗播放器IDE
- Yet Another Problem
- Nanami and the Constructive ProblemNaNStruct
- 2019 MCM Problem A
- 戳戳HackShield Ring0反除錯除錯
- E. Not a Nim Problem
- Nanami and the House Protecting ProblemNaN
- HDU - 6182 A Math Problem
- Problem A. Ascending Rating
- Fixed "There was a problem with the editor 'vi'"
- Improving the speed of the Miller-Rabin Prime Test
- P1865 A % B Problem
- Assignment Problem的若干思考
- A + B Problem II hd 1002
- Joe Harris is a real problem with this team
- Follow/Unfollow problem in system design
- Euclid Problem - PC110703
- HDU 1002 A + B Problem II
- POJ 2355 Railway Ticket problemAI
- The Door Problem 並查集並查集
- HDU 1792 A New Change Problem
- Solution - Atcoder ABC263G Erasing Prime PairsAI
- Prime Path(POJ - 3126)【BFS+篩素數】
- Diff-prime Pairs(思維+素數篩)AI
- ESTR1002 Problem Solving by Programming
- ECE 498/598 Associative Recall Problem
- Yuhao Du Contest 7 - Junk Problem
- CF1987F Interesting ProblemREST