Hdu 1792 A New Change Problem 結論

這樣啊我也喜歡發表於2018-10-15

 

Problem Description

Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.

 

 

Input

The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line.

 

 

Output

For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.

 

 

Sample Input

 

2 3

3 4

 

 

Sample Output

 

1 1

5 3

題意:
求兩個互質數的最大不能組成的數和不能組成的數的個數....

網上找的公式.....

最大不能組成的數為a*b-a-b;

不能組成的數為(a-1)*(b-1)/2;

程式碼如下:
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int a,b;
int main()
{
    while (scanf("%d%d",&a,&b)!=EOF)
    {
        printf("%d %d\n",a*b-a-b,(a-1)*(b-1)/2);
    }
    return 0;
}

 

相關文章