HDU 6058 Kanade's sum(連結串列)

Mr_Treeeee發表於2020-04-06

Kanade's sum

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2320    Accepted Submission(s): 956


Problem Description
Give you an array A[1..n]of length n

Let f(l,r,k) be the k-th largest element of A[l..r].

Specially , f(l,r,k)=0 if rl+1<k.

Give you k , you need to calculate nl=1nr=lf(l,r,k)

There are T test cases.

1T10

kmin(n,80)

A[1..n] is a permutation of [1..n]

n5105
 

Input
There is only one integer T on first line.

For each test case,there are only two integers n,k on first line,and the second line consists of n integers which means the array A[1..n]
 

Output
For each test case,output an integer, which means the answer.
 

Sample Input
1 5 2 1 2 3 4 5
 

Sample Output
30
 

Source
 
題意:
給你一個排列,求所有區間[l,r]內第k大的數,若沒有第k大的數,就為0。求和。
POINT:
建立一個物理意義上的連結串列,來連線這個排列。
排列固定是1-n的數。所以先從1開始找。那麼順著連結串列往前和往後都是比1大的,往前最多找k-1個數,往後也一樣。
這樣往前找0個數,對應往後找k-1個數。往前找1個數,對應往後找k-2個數。依此類推。
只要求出往前找(0-k-1)個數的時候有幾種可能,記錄l陣列。同理對r陣列一樣的操作。
答案就是對應的l乘r。
找完1就把1刪了,找2。
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
using namespace std;
#define LL long long
const int N = 5*1e5+33;
int pre[N],nxt[N],pos[N],l[N],r[N];
LL ans;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,k;
        ans=0;
        scanf("%d %d",&n,&k);
        for(int i=1;i<=n;i++)
        {
            int a;
            scanf("%d",&a);
            pos[a]=i;
        }
        for(int i=1;i<=n;i++)
        {
            pre[i]=i-1;
            nxt[i]=i+1;
        }
        for(int i=1;i<=n;i++)
        {
            int l_cnt=0;
            int r_cnt=0;
            for(int j=pos[i];j>=1&&l_cnt<k;j=pre[j])
            {
                l[l_cnt++]=j-pre[j];
            }
            for(int j=pos[i];j<=n&&r_cnt<k;j=nxt[j])
            {
                r[r_cnt++]=nxt[j]-j;
            }
            for(int j=0;j<l_cnt;j++)
            {
                if(k-1-j<r_cnt)
                {
                    ans+=(LL)l[j]*r[k-1-j]*i;
                }
            }
            pre[nxt[pos[i]]]=pre[pos[i]];
            nxt[pre[pos[i]]]=nxt[pos[i]];
        }
        printf("%lld\n",ans);
    }
    return 0;
}




相關文章