資料結構實驗之連結串列九:雙向連結串列

HowieLee59發表於2019-03-12

Problem Description

學會了單向連結串列,我們又多了一種解決問題的能力,單連結串列利用一個指標就能在記憶體中找到下一個位置,這是一個不會輕易斷裂的鏈。但單連結串列有一個弱點——不能回指。比如在連結串列中有兩個節點A,B,他們的關係是B是A的後繼,A指向了B,便能輕易經A找到B,但從B卻不能找到A。一個簡單的想法便能輕易解決這個問題——建立雙向連結串列。在雙向連結串列中,A有一個指標指向了節點B,同時,B又有一個指向A的指標。這樣不僅能從連結串列頭節點的位置遍歷整個連結串列所有節點,也能從連結串列尾節點開始遍歷所有節點。對於給定的一列資料,按照給定的順序建立雙向連結串列,按照關鍵字找到相應節點,輸出此節點的前驅節點關鍵字及後繼節點關鍵字。

Input

第一行兩個正整數n(代表節點個數),m(代表要找的關鍵字的個數)。第二行是n個數(n個數沒有重複),利用這n個數建立雙向連結串列。接下來有m個關鍵字,每個佔一行。

Output

對給定的每個關鍵字,輸出此關鍵字前驅節點關鍵字和後繼節點關鍵字。如果給定的關鍵字沒有前驅或者後繼,則不輸出。
注意:每個給定關鍵字的輸出佔一行。
           一行輸出的資料之間有一個空格,行首、行末無空格。

 

Sample Input

10 3
1 2 3 4 5 6 7 8 9 0
3
5
0

Sample Output

2 4
4 6
9

Hint

 

#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;

typedef struct Node{
    int data;
    struct Node *prime;
    struct Node *next;
}node;

int count = 0;

void create(node * &head,int n){
    node *p,*tail;
    head = new Node;
    head->next = NULL;
    tail = head;
    for(int i = 0 ;i < n;i++){
        p = new Node;
        scanf("%d",&p->data);
        p->next = NULL;
        p->prime = tail;
        tail->next = p;
        tail = p;
    }
}

void print(node * &head,int m){
    int key;
    node *p;
    while(m--){
        p = head->next;
        scanf("%d",&key);
        while(p){
            if(p->data == key){
                if(p->prime != head&&p->next != NULL){
                    printf("%d %d\n",p->prime->data,p->next->data);
                    break;
                }else if(p->prime != head&&p->next == NULL){
                    printf("%d\n",p->prime->data);
                    break;
                }
                else if(p->next != NULL&&p->prime == head){
                    printf("%d\n",p->next->data);
                    break;
                }
            }
            p = p->next;
        }
    }
}

int main(){
    node *head;
    int n, m;
    scanf("%d %d", &n, &m);
    count = n;
    create(head, n);
    print(head, m);

}

 

相關文章