HDU 6033 Add More Zero (數學)
Add More Zero
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 302 Accepted Submission(s): 223
Problem Description
There is a youngster known for amateur propositions concerning several mathematical hard problems.
Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).
As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1to 10k (inclusive).
For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.
Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.
Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).
As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1to 10k (inclusive).
For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.
Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.
Input
The input contains multiple test cases. Each test case in one line contains only one positive integer m,
satisfying 1≤m≤105.
Output
For each test case, output "Case #x: y"
in one line (without quotes), where x indicates
the case number starting from 1 and y denotes
the answer of corresponding case.
Sample Input
1
64
Sample Output
Case #1: 0
Case #2: 19
Source
題意:
求出最大k,使10^k>=2^m-1,給出m。
point:
你敢相信這種簽到題我們這種殘疾隊做了1個半小時?????根本沒往數學方面想,光想著打表暴力求解了。
一個簡單的答案 k=m*(log2/log10).向下取整。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
#define rt x<<1|1
#define lt x<<1
#define LL long long
int main()
{
int m;
int p=0;
while(~scanf("%d",&m))
{
printf("Case #%d: ",++p);
printf("%.0f\n",floor(m*1.0*(log(2.0)/log(10.0))));
}
}
現場AC的程式碼,因為精度問題WA了5發也是辛苦我了。//賽中知道正規的解題方案很想一頭撞死了,高中數學老師都要提刀砍我了。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
#define rt x<<1|1
#define lt x<<1
#define LL long long
int ans[100000+5];
int main()
{
LL now;
for(int i=1;i<=59;i++)
{
now=(LL)pow(2,i);
int l=0;
while(now)
{
now/=10;
l++;
}
ans[i]=l-1;
}
now=(LL)pow(2,59);
for(int i=60;i<=100000;i++)
{
now=now*2;
if(now>=1e18)
{
ans[i]=ans[i-1]+1;
now=now/10;
}
else
{
ans[i]=ans[i-1];
}
}
int n;
int p=0;
while(~scanf("%d",&n))
{
printf("Case #%d: %d\n",++p,ans[n]);
}
return 0;
}
相關文章
- HDU 5773 The All-purpose Zero 求LIS
- 【dp+組合數學】hdu 2018 多校第九場 1001 Rikka with Nash Equilibrium hdu 6415UI
- HDU 6415 (計數dp)
- hdu2084數塔
- Zero Copy 學習總結
- filebeat配置引數add_kubernetes_metadata
- hdu1297大數遞迴遞迴
- LeetCode2: Add two numbers(兩數相加)LeetCode
- 文獻學習——Making Deduction More Effective in SAT Solvers
- go-zero學習之RPC呼叫GoRPC
- <hdu-OJ>|| 2040_親和數
- HDU 1060 Leftmost Digit(數論,c++)GitC++
- Fifth. LeetCode 2:Add Two Numbers 兩數之和LeetCode
- hdu 2111 Saving HDU (DP)
- git add all和git add .區別Git
- HDU 6034 Balala Power!(大數進位制)
- 4.5.1 add
- MORE_DETAIL_TECHAI
- TypeScript 之 More on FunctionsTypeScriptFunction
- 一文搞懂 ARM 64 系列: ADD(立即數版)
- Make It Zero
- go zeroGo
- More web function requests go online concurrently, and web service deployment is faster and more economical!WebFunctionGoAST
- go-zero學習之註冊登入Go
- Zero-shot Learning零樣本學習 論文閱讀(三)——Semantic Autoencoder for Zero-Shot Learning
- Oracle設定日誌引數-ALTER DATABASE ADD SUPPLEMENTAL LOG DATA;OracleDatabase
- hdu 5698 瞬間移動 【質因數分解求組合數】
- Vegetables need more practice.
- B-A Bit More Common
- Compare two or more repo directories
- DNS: More than just namesDNS
- LIFE2020-make-more
- Linux基礎命令---moreLinux
- 華為桌面雲報故障6033:SSL認證存在錯誤
- DataTransferItemList.add()
- 2.3 ADD CREDENTIALSTORE
- 2.2 ADD CHECKPOINTTABLE
- git add errorGitError