HDU 3006 The Number of set (狀態壓縮)
The Number of set
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1472 Accepted Submission(s): 921
Problem Description
Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The
input is end by EOF.
Output
For each case,the output contain only one integer,the number of the different sets you get.
Sample Input
4 4
1 1
1 2
1 3
1 4
2 4
3 1 2 3
4 1 2 3 4
Sample Output
15
2
Source
題意:
給你N個集合,求出N個集合相互組合後最多的集合數。
POINT:
狀態壓縮:
即把每個數字取與不取用1和0表示,這樣得到一排101010即二進位制數,之後用各種位運算來實現各種操作。
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <queue>
#include <algorithm>
#include <map>
#include <math.h>
using namespace std;
#define ll long long
int a[(1<<15)+1];
int main()
{
int n,m;
while(~scanf("%d %d",&n,&m))
{
memset(a,0,sizeof a);
for(int i=1;i<=n;i++)
{
int num;
scanf("%d",&num);
int k=0;
for(int j=1;j<=num;j++)
{
int a;
scanf("%d",&a);
k+=1<<(a-1);
}
a[k]=1;
for(int j=1;j<=(1<<m);j++)
{
if(a[j])
{
a[k|j]=1;//k|j代表把兩種集合結合。
}
}
}
int ans=0;
for(int i=1;i<=(1<<m);i++)
{
if(a[i]) ans++;
}
printf("%d\n",ans);
}
}
相關文章
- HDU 5816 Hearthstone(狀態壓縮DP+概率)
- hdu--5418Victor and World+狀態壓縮DP
- 狀態壓縮
- 簡易狀態壓縮DP
- 論文閱讀 狀態壓縮
- POJ3279 Fliptile【狀態壓縮+DFS】
- HDU 1074 Doing Homework(狀壓DP)
- 動態規劃中初識狀態壓縮(入門)動態規劃
- POJ 2777 Count Color (線段樹+狀態壓縮)
- 狀壓 + 網路流 -- Escape HDU - 3605
- bzoj4145: [AMPPZ2014]The Prices(狀態壓縮+Dp)
- HDU 1711 Number Sequence(KMP)KMP
- 動態規劃——用二進位制表示集合的狀態壓縮DP動態規劃
- HDU2665 Kth number【主席樹】
- Nginx網路壓縮 CSS壓縮 圖片壓縮 JSON壓縮NginxCSSJSON
- HDU 1005 Number Sequence(矩陣快速冪)矩陣
- 檔案壓縮和解壓縮
- ACM-ICPC 2018 南京賽區網路預賽__E AC Challenge【狀態壓縮+DP】ACM
- HDU 1394 Minimum Inversion Number (暴力+線段樹)
- Python實現壓縮和解壓縮Python
- JS壓縮方法及批量壓縮JS
- linux下壓縮解壓縮命令Linux
- linux壓縮和解壓縮命令整理Linux
- CSP之壓縮編碼(動態規劃)動態規劃
- Linux tar分卷壓縮與解壓縮Linux
- HDU5972Regular Number(ShiftAnd演算法 bitset)演算法
- CentOS 壓縮解壓CentOS
- Linux壓縮解壓Linux
- linux 高效壓縮工具之xz的壓縮解壓使用Linux
- Linux中檔案的壓縮和解壓縮Linux
- Gzipped 壓縮
- 打包/壓縮
- linux分卷壓縮解壓Linux
- linuxtar解壓和壓縮Linux
- 壓縮包格式有哪些?壓縮包格式大全
- ppt怎麼壓縮,ppt壓縮的技巧分享
- 壓縮Word,一鍵實現Word文件壓縮
- 分卷壓縮怎麼解壓 快速解壓電腦分卷壓縮檔案方法