HDU 3006 The Number of set (狀態壓縮)

Mr_Treeeee發表於2020-04-06

The Number of set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1472    Accepted Submission(s): 921


Problem Description
Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
 

Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
 

Output
For each case,the output contain only one integer,the number of the different sets you get.
 

Sample Input
4 4 1 1 1 2 1 3 1 4 2 4 3 1 2 3 4 1 2 3 4
 

Sample Output
15 2
 

Source
 

題意:
給你N個集合,求出N個集合相互組合後最多的集合數。

POINT:
狀態壓縮:
即把每個數字取與不取用1和0表示,這樣得到一排101010即二進位制數,之後用各種位運算來實現各種操作。
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <queue>
#include <algorithm>
#include <map>
#include <math.h>
using namespace std;
#define ll long long
int a[(1<<15)+1];
int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        memset(a,0,sizeof a);
        for(int i=1;i<=n;i++)
        {
            int num;
            scanf("%d",&num);
            int k=0;
            for(int j=1;j<=num;j++)
            {
                int a;
                scanf("%d",&a);
                k+=1<<(a-1);
            }
            a[k]=1;
            for(int j=1;j<=(1<<m);j++)
            {
                if(a[j])
                {
                    a[k|j]=1;//k|j代表把兩種集合結合。
                }
            }
        }
        int ans=0;
        for(int i=1;i<=(1<<m);i++)
        {
            if(a[i]) ans++;
        }
        printf("%d\n",ans);
    }
}


相關文章