HDU 5816 Hearthstone(狀態壓縮DP+概率)
Hearthstone
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1119 Accepted Submission(s): 554
Problem Description
Hearthstone is an online collectible card game from Blizzard Entertainment. Strategies and luck are the most important factors in this game. When you suffer a desperate situation and your only hope depends on the top of the card deck, and you draw the only
card to solve this dilemma. We call this "Shen Chou Gou" in Chinese.
Now you are asked to calculate the probability to become a "Shen Chou Gou" to kill your enemy in this turn. To simplify this problem, we assume that there are only two kinds of cards, and you don't need to consider the cost of the cards.
-A-Card: If the card deck contains less than two cards, draw all the cards from the card deck; otherwise, draw two cards from the top of the card deck.
-B-Card: Deal X damage to your enemy.
Note that different B-Cards may have different X values.
At the beginning, you have no cards in your hands. Your enemy has P Hit Points (HP). The card deck has N A-Cards and M B-Cards. The card deck has been shuffled randomly. At the beginning of your turn, you draw a card from the top of the card deck. You can use all the cards in your hands until you run out of it. Your task is to calculate the probability that you can win in this turn, i.e., can deal at least P damage to your enemy.
Now you are asked to calculate the probability to become a "Shen Chou Gou" to kill your enemy in this turn. To simplify this problem, we assume that there are only two kinds of cards, and you don't need to consider the cost of the cards.
-A-Card: If the card deck contains less than two cards, draw all the cards from the card deck; otherwise, draw two cards from the top of the card deck.
-B-Card: Deal X damage to your enemy.
Note that different B-Cards may have different X values.
At the beginning, you have no cards in your hands. Your enemy has P Hit Points (HP). The card deck has N A-Cards and M B-Cards. The card deck has been shuffled randomly. At the beginning of your turn, you draw a card from the top of the card deck. You can use all the cards in your hands until you run out of it. Your task is to calculate the probability that you can win in this turn, i.e., can deal at least P damage to your enemy.
Input
The first line is the number of test cases T (T<=10).
Then come three positive integers P (P<=1000), N and M (N+M<=20), representing the enemy’s HP, the number of A-Cards and the number of B-Cards in the card deck, respectively. Next line come M integers representing X (0<X<=1000) values for the B-Cards.
Then come three positive integers P (P<=1000), N and M (N+M<=20), representing the enemy’s HP, the number of A-Cards and the number of B-Cards in the card deck, respectively. Next line come M integers representing X (0<X<=1000) values for the B-Cards.
Output
For each test case, output the probability as a reduced fraction (i.e., the greatest common divisor of the numerator and denominator is 1). If the answer is zero (one), you should output 0/1 (1/1) instead.
Sample Input
2
3 1 2
1 2
3 5 10
1 1 1 1 1 1 1 1 1 1
Sample Output
1/3
46/273
Author
SYSU
Source
題意:
給你N張奧數智慧,M張火球術(不打6) 打幾下面給出。求出摸1張牌打出>=P傷害的概率。
POINT:
遍歷各種摸牌可能。DP[i]代表當前i狀態的數量。詳細解釋在程式碼裡。
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stack>
#include <algorithm>
#include <math.h>
using namespace std;
#define ll long long
ll f[26],dp[1<<20];
int P,N,M;
int atk[20];
void init()
{
f[1]=1;
f[0]=1;
for(int i=2;i<=20;i++) f[i]=f[i-1]*i;
}
int check(int now)
{
int sum=0;
now=now>>N;
for(int i=0;i<M;i++)
{
if(now&(1<<i))
{
sum+=atk[i];
}
}
if(sum>=P) return 1;
return 0;
}
ll gcd(ll a,ll b)
{
return a==0?b:gcd(b%a,a);
}
int main()
{
init();
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d %d %d",&P,&N,&M);
memset(dp,0,sizeof dp);
for(int i=0;i<(N+M);i++) dp[1<<i]=1;
for(int i=0;i<M;i++)
{
scanf("%d",&atk[i]);
}
int amark=(1<<N)-1;
int tot=(1<<(N+M))-1;
ll ans=0;
for(int i=0;i<=tot;i++)
{
int have = __builtin_popcount(i);
int left = N+M-have;
int havea= __builtin_popcount(i&amark);
if(check(i))
{
ans+=dp[i]*f[left];//當前的狀態的數量*之後的全排序。
continue;
}
if(havea*2+1-have<=0) continue;//無牌可摸
for(int j=0;j<N+M;j++)
{
if(!((i>>j)&1))
{
dp[i|(1<<j)]+=dp[i];//摸一張牌,加上之前的數量。
}
}
}
ll d=gcd(ans,f[N+M]);
printf("%lld/%lld\n",ans/d,f[N+M]/d);
}
}
相關文章
- HDU 3006 The Number of set (狀態壓縮)
- hdu--5418Victor and World+狀態壓縮DP
- 狀態壓縮
- 簡易狀態壓縮DP
- 論文閱讀 狀態壓縮
- E - Remove Pairs(狀壓dp+博弈論)REMAI
- POJ3279 Fliptile【狀態壓縮+DFS】
- HDU 1074 Doing Homework(狀壓DP)
- 分組(狀壓dp+技巧:快速列舉子集)
- 動態規劃中初識狀態壓縮(入門)動態規劃
- POJ 2777 Count Color (線段樹+狀態壓縮)
- 狀壓 + 網路流 -- Escape HDU - 3605
- bzoj4145: [AMPPZ2014]The Prices(狀態壓縮+Dp)
- CF79D Password (差分+狀壓 dp+最短路/bfs)
- 動態規劃——用二進位制表示集合的狀態壓縮DP動態規劃
- Nginx網路壓縮 CSS壓縮 圖片壓縮 JSON壓縮NginxCSSJSON
- 【dp+組合數學】hdu 2018 多校第九場 1001 Rikka with Nash Equilibrium hdu 6415UI
- 檔案壓縮和解壓縮
- ACM-ICPC 2018 南京賽區網路預賽__E AC Challenge【狀態壓縮+DP】ACM
- Python實現壓縮和解壓縮Python
- JS壓縮方法及批量壓縮JS
- linux下壓縮解壓縮命令Linux
- linux壓縮和解壓縮命令整理Linux
- CSP之壓縮編碼(動態規劃)動態規劃
- Linux tar分卷壓縮與解壓縮Linux
- CentOS 壓縮解壓CentOS
- Linux壓縮解壓Linux
- linux 高效壓縮工具之xz的壓縮解壓使用Linux
- Linux中檔案的壓縮和解壓縮Linux
- Gzipped 壓縮
- 打包/壓縮
- linux分卷壓縮解壓Linux
- linuxtar解壓和壓縮Linux
- 壓縮包格式有哪些?壓縮包格式大全
- ppt怎麼壓縮,ppt壓縮的技巧分享
- 壓縮Word,一鍵實現Word文件壓縮
- 分卷壓縮怎麼解壓 快速解壓電腦分卷壓縮檔案方法
- Linux 常用的壓縮與解壓縮命令詳解Linux