HDU 1074 Doing Homework(狀壓DP)
Doing Homework
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 9486 Accepted Submission(s): 4481
Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).
Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).
Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
Sample Input
2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3
Sample Output
2
Computer
Math
English
3
Computer
English
Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the
word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
Author
Ignatius.L
題意:
給出每個作業的截止日期和長度,晚了截止日期幾天完成就扣幾分。求最小扣分。
POINT:
Nmax=15,所以用狀態壓縮做。題目裡說了用字典序,但是它自己已經排好了,所以不用管。
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stack>
#include <algorithm>
#include <math.h>
using namespace std;
#define ll long long
struct node
{
int day;
int score;
int pre;
}dp[1<<15];
struct ode
{
string name;
int end;
int l;
}a[16];
int flag[1<<15];
void pree(int x)
{
stack<int> q;
while(x!=0)
{
q.push(x);
x=dp[x].pre;
}
int now=0;
while(!q.empty())
{
int w=now^q.top();
int wei=log(w)/log(2);
cout<<a[wei].name<<endl;
now=q.top();
q.pop();
}
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n;
scanf("%d",&n);
memset(dp,0,sizeof dp);
memset(flag,0,sizeof flag);
for(int i=0;i<n;i++)
{
cin>>a[i].name>>a[i].end>>a[i].l;
}
dp[0].day=0;
dp[0].pre=-1;
dp[0].score=0;
for(int i=0;i<=(1<<n)-1;i++)
{
for(int j=0;j<n;j++)
{
if(((1<<j)&i)==1) continue;
int newi=(1<<j)|i;
int newday=dp[i].day+a[j].l;
int addscore=0;
if(newday>a[j].end)
{
addscore=newday-a[j].end;
}
int newscore=dp[i].score+addscore;
if(flag[newi])
{
if(newscore<dp[newi].score)
{
dp[newi].day=newday;
dp[newi].pre=i;
dp[newi].score=newscore;
}
}
else
{
flag[newi]=1;
dp[newi].day=newday;
dp[newi].pre=i;
dp[newi].score=newscore;
}
}
}
printf("%d\n",dp[(1<<n)-1].score);
pree((1<<n)-1);
}
}
相關文章
- [kuangbin帶你飛]專題十二 基礎DP1 D - Doing Homework HDU - 1074
- HDU 5816 Hearthstone(狀態壓縮DP+概率)
- hdu--5418Victor and World+狀態壓縮DP
- 狀壓DP
- 狀壓 dp
- [狀壓dp] 最短Hamilton路徑(模板題+狀壓dp)
- hdu 2111 Saving HDU (DP)
- 狀壓DP基礎入門
- 簡易狀態壓縮DP
- HDU 3006 The Number of set (狀態壓縮)
- 狀壓 + 網路流 -- Escape HDU - 3605
- hdu 6415 - DP
- 合理安排(狀壓dp,包括技巧)
- E - Remove Pairs(狀壓dp+博弈論)REMAI
- NOI2001 炮兵陣地(狀壓dp)
- HDU1024(dp)
- HDU6415(DP)
- HDU 6415 (計數dp)
- Luogu P1777 幫助 題解 [ 紫 ] [ 線性 dp ] [ 狀壓 dp ]
- 分組(狀壓dp+技巧:快速列舉子集)
- HDU 6415 Rikka with Nash Equilibrium (DP)UI
- Codeforces 11D A Simple Task 題解 [ 藍 ] [ 狀壓 dp ]
- bzoj4145: [AMPPZ2014]The Prices(狀態壓縮+Dp)
- HDU 6035 Colorful Tree(樹形DP)
- HDU6415:Rikka with Nash Equilibrium(dp)UI
- 百練4124:海賊王之偉大航路(狀壓DP)
- HDU4652 Dice(期望dp推式子)
- HDU 6415(dp/記憶化搜尋)
- CF79D Password (差分+狀壓 dp+最短路/bfs)
- 一類哈密頓路徑/迴路為背景的狀壓dp
- HDU多校第九次 6415 (dp
- leo-doing
- [狀壓dp]leeccode1434:每個人戴不同帽子的方案數(hard)
- 1074 reverse list
- HDU-6415 Rikka with Nash Equilibrium (DP/找規律)UI
- 動態規劃——用二進位制表示集合的狀態壓縮DP動態規劃
- homework
- 「暑期訓練」「基礎DP」 Monkey and Banana (HDU-1069)NaN