HDU2665 Kth number【主席樹】
Kth number
Time Limit: 15000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16583 Accepted Submission(s): 5076
Problem Description
Give you a sequence and ask you the kth big number of a inteval.
Input
The first line is the number of the test cases.
For each test case, the first line contain two integer n and m (n, m <= 100000), indicates the number of integers in the sequence and the number of the quaere.
The second line contains n integers, describe the sequence.
Each of following m lines contains three integers s, t, k.
[s, t] indicates the interval and k indicates the kth big number in interval [s, t]
Output
For each test case, output m lines. Each line contains the kth big number.
Sample Input
1
10 1
1 4 2 3 5 6 7 8 9 0
1 3 2
Sample Output
2
Source
HDU男生專場公開賽——趕在女生之前先過節(From WHU)
題解:區間第K個數,靜態區間可使用劃分樹和主席樹,使用主席樹的題解如下
AC的C++程式碼:
#include<iostream>
#include<algorithm>
using namespace std;
const int N=100010;
int a[N],b[N],rt[N*20],ls[N*20],rs[N*20],sum[N*20];
int id;
void build(int &o,int l,int r)
{
o=++id;
sum[o]=0;
if(l==r) return;
int m=(l+r)>>1;
build(ls[o],l,m);
build(rs[o],m+1,r);
}
void update(int &o,int l,int r,int last,int p)
{
o=++id;
ls[o]=ls[last];
rs[o]=rs[last];
sum[o]=sum[last]+1;
if(l==r) return;
int m=(l+r)>>1;
if(p<=m)
update(ls[o],l,m,ls[last],p);
else
update(rs[o],m+1,r,rs[last],p);
}
int query(int s,int e,int l,int r,int k)
{
if(l==r) return l;
int m=(l+r)>>1;
int cnt=sum[ls[e]]-sum[ls[s]];
if(cnt>=k)
return query(ls[s],ls[e],l,m,k);
else
return query(rs[s],rs[e],m+1,r,k-cnt);
}
int main()
{
int t,n,q,l,r,k;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&q);
for(int i=1;i<=n;i++){
scanf("%d",&a[i]);
b[i]=a[i];
}
sort(b+1,b+1+n);
int size=unique(b+1,b+1+n)-(b+1);
id=0;
build(rt[0],1,size);
for(int i=1;i<=n;i++){
a[i]=lower_bound(b+1,b+1+size,a[i])-b;
update(rt[i],1,size,rt[i-1],a[i]);
}
while(q--){
scanf("%d%d%d",&l,&r,&k);
int pos=query(rt[l-1],rt[r],1,size,k);
printf("%d\n",b[pos]);
}
}
return 0;
}
相關文章
- 主席樹
- 主席樹模板
- 靜態主席樹模板
- 動態主席樹模板
- D-query SPOJ - DQUERY (主席樹)
- HDU4417 Super Mario【主席樹】
- BZOJ4299: Codechef FRBSUM(主席樹)
- 【資料結構】淺談主席樹資料結構
- 洛谷P4197 Peaks(Kruskal重構樹 主席樹)
- 【主席數】可持續化線段樹
- SDOI2018 原題識別(主席樹)
- bzoj3524: [Poi2014]Couriers(主席樹)
- HDU-4348 - To the moon (主席樹+區間修改)
- 【主席樹】P3919 【模板】可持久化線段樹 1持久化
- 演算法隨筆——主席樹(可持久化線段樹)演算法持久化
- bzoj3545: [ONTAK2010]Peaks(主席樹+最小生成樹)
- bzoj4477: [Jsoi2015]字串樹(主席樹+Hash+Lca)JS字串
- bzoj3439: Kpm的MC密碼(主席樹+DFS序+字典樹)密碼
- bzoj2809: [Apio2012]dispatching(DFS序+主席樹)API
- 求區間不同數的個數【主席樹求解】
- bzoj5178: [Jsoi2011]棒棒糖(主席樹)JS
- bzoj1112: [POI2008]磚塊Klo(主席樹)
- bzoj2588: Spoj 10628. Count on a tree(主席樹+LCA)
- HDU 1394 Minimum Inversion Number (暴力+線段樹)
- 2024年3月21日 懸繩法 + 珂朵莉樹(ODT) + 主席樹
- 可持久化線段————主席樹(洛谷p3834)持久化
- bzoj3110: [Zjoi2013]K大數查詢(主席樹+樹狀陣列)陣列
- LeetCode Kth Largest Element in an ArrayLeetCode
- POJ2104 K-th Number【劃分樹】
- 洛谷 P3919 可持久化線段樹 1 之主席樹模板(初級)持久化
- bzoj1146: [CTSC2008]網路管理Network(dfs序+主席樹+樹狀陣列)陣列
- bzoj1803: Spoj1487 Query on a tree III(DFS序+主席樹)
- bzoj4448: [Scoi2015]情報傳遞(主席樹+Lca)
- bzoj5177: [Jsoi2013]貪心的導遊(主席樹)JS
- bzoj3207: 花神的嘲諷計劃Ⅰ(hash+主席樹)
- 215. Kth Largest Element in an Array
- bzoj2733: [HNOI2012]永無鄉(並查集+主席樹)並查集
- bzoj3932: [CQOI2015]任務查詢系統(主席樹)