HDU 1541 & POJ 2352 Stars (樹狀陣列)
Stars
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 9874 Accepted Submission(s): 3959
Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars.
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Source
題意:
給你一個二維的星星圖,讓你求出每個星星的左下有幾顆星星並輸出有(0-n-1)顆星星的數量。
POINT:
由於題目是按照y遞增的順序給出星星,就直接記錄x位置星星有幾顆,樹狀陣列記錄區間(1-x)星星有幾顆就行了。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <map>
#include <algorithm>
using namespace std;
#define rt x<<1|1
#define lt x<<1
const int N = 32000*10;
#define LL long long
int sum[N];
int n;
int maxn;
int lowbit(int x)
{
return x&-x;
}
void add(int x,int c)
{
while(x<=32001)
{
sum[x]+=c;
x+=lowbit(x);
}
}
int query(int x)
{
int ans=0;
while(x>=1)
{
ans+=sum[x];
x-=lowbit(x);
}
return ans;
}
int main()
{
int ans[15010];
while(~scanf("%d",&n))
{
memset(sum,0,sizeof sum);
memset(ans,0,sizeof ans);
int x;
int y;
for(int i=1;i<=n;i++)
{
scanf("%d %d",&x,&y);
ans[query(x+1)]++;
add(x+1,1);
}
for(int i=0;i<n;i++)
{
printf("%d\n",ans[i]);
}
}
return 0;
}
相關文章
- POJ-2352 Stars(樹狀陣列)陣列
- HDU 1556 Color the ball(線段樹|樹狀陣列)陣列
- HDU 2689 Sort it【樹狀陣列求逆序對】陣列
- HDU 6274 Master of Sequence(思維+樹狀陣列+二分)AST陣列
- HDU 1556【區間更新+單點查詢 樹狀陣列】陣列
- 樹狀陣列陣列
- HDU 5862 Counting Intersections(樹狀陣列+掃描線+離散化)陣列
- POJ3468 A Simple Problem with Integers---樹狀陣列(區間問題)陣列
- 解析樹狀陣列陣列
- POJ 3468 【區間修改+區間查詢 樹狀陣列 | 線段樹 | 分塊】陣列
- HDU1166 敵兵佈陣【樹狀陣列 單點修改+區間查詢】陣列
- 二維樹狀陣列陣列
- 樹狀陣列詳解陣列
- 樹狀陣列基礎陣列
- 樹狀陣列模板題 & (樹狀陣列 1:單點修改,區間查詢)陣列
- 樹狀陣列快速入門陣列
- 樹狀陣列和逆序對陣列
- 【筆記/模板】樹狀陣列筆記陣列
- 樹狀陣列模板+習題集陣列
- 樹狀陣列(我是真小白)陣列
- 資料結構——樹狀陣列資料結構陣列
- 樹狀陣列3種基本操作陣列
- bzoj3155: Preprefix sum(樹狀陣列)陣列
- 【luogu3368】模板 樹狀陣列 2陣列
- 洛谷題單指南-二叉堆與樹狀陣列-P3368 【模板】樹狀陣列 2陣列
- CHOJ 4201 樓蘭圖騰【樹狀陣列】陣列
- AC自動機+字典序+樹狀陣列陣列
- 樹狀陣列(BIT)—— 一篇就夠了陣列
- 樹狀陣列(待補)(生硬 公式 用法 證明)陣列公式
- 資料結構之真別多想—樹狀陣列資料結構陣列
- bzoj2743: [HEOI2012]採花(樹狀陣列)陣列
- 樹狀陣列入門陣列
- LeetCode C++ 劍指 Offer 51. 陣列中的逆序對【歸併排序/樹狀陣列/線段樹】LeetCodeC++陣列排序
- PHP 陣列轉樹結構/樹結構轉陣列PHP陣列
- 求區間不同數的個數【樹狀陣列求解】陣列
- 實驗室外的攻防戰 UOJ#180 [樹狀陣列]陣列
- 樹狀陣列的區間查詢與區間修改陣列
- POJ 2777 Count Color (線段樹+狀態壓縮)