HDU 2689 Sort it【樹狀陣列求逆序對】

神探小小迪發表於2018-09-26

Problem Description

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

Output

For each case, output the minimum times need to sort it in ascending order on a single line.

Sample Input

3

1 2 3

4

4 3 2 1

Sample Output

0

6

題解:倒著求,每次統計 a[i]後邊有多少個比它小,同時更新a[i]出現的次數。(樹狀陣列維護的是字首和......牢記)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 1005;
int n;
int a[maxn], c[maxn];
int lowbit(int x) {
    return x & -x;
}
int get_sum(int x){
    int sum = 0;
    while(x){
        sum += c[x];
        x -= lowbit(x);
    }
    return sum;
}
void add(int x, int val) {
    while(x <= n){
        c[x] += val;
        x += lowbit(x);
    }
}
int main()
{
    while(~scanf("%d", &n)){
        memset(c, 0, sizeof c);
        for(int i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
        }
        int ans = 0;
        for(int i = n; i >= 1; i--){//倒序統計
            ans += get_sum(a[i] - 1);//查詢a[i]後邊有多少個數比它小
            add(a[i], 1);//a[i]出現的次數+1
        }
        printf("%d\n", ans);
    }
    return 0;
}

 

相關文章