HDU 1556【區間更新+單點查詢 樹狀陣列】

神探小小迪發表於2018-09-27

N個氣球排成一排,從左到右依次編號為1,2,3....N.每次給定2個整數a b(a <= b),lele便為騎上他的“小飛鴿"牌電動車從氣球a開始到氣球b依次給每個氣球塗一次顏色。但是N次以後lele已經忘記了第I個氣球已經塗過幾次顏色了,你能幫他算出每個氣球被塗過幾次顏色嗎?

Input

每個測試例項第一行為一個整數N,(N <= 100000).接下來的N行,每行包括2個整數a b(1 <= a <= b <= N)。 
當N = 0,輸入結束。

Output

每個測試例項輸出一行,包括N個整數,第I個數代表第I個氣球總共被塗色的次數。

Sample Input

3
1 1
2 2
3 3
3
1 1
1 2
1 3
0

Sample Output

1 1 1
3 2 1

題解:P199。

#include<bits/stdc++.h> 
using namespace std;
const int maxn=100005;
int n;
int a[maxn];
int lowbit(int x){
	return x&-x;
}
void update(int x,int w){
	while(x<=n){
		a[x]+=w;
		x+=lowbit(x);
	}
}
int getsum(int x){
	int sum=0;
	while(x>0){
		sum+=a[x];
		x-=lowbit(x);
	}
	return sum;
}
int main(){
	int A,b;
	while(cin>>n&&n){
		memset(a,0,sizeof a);
		int t=n;
		for(int i=1;i<=n;i++){
			cin>>A>>b;
			update(A,1);
			update(b+1,-1);
		}
		for(int i=1;i<t;i++){
			printf("%d ",getsum(i));
		}
		printf("%d\n",getsum(t));
	}
	return 0;
}

 

相關文章