HDU1754 I Hate It 【線段樹基礎:點修改+區間查詢】

Enjoy_process發表於2018-09-02

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 103810    Accepted Submission(s): 39022


 

Problem Description

很多學校流行一種比較的習慣。老師們很喜歡詢問,從某某到某某當中,分數最高的是多少。
這讓很多學生很反感。不管你喜不喜歡,現在需要你做的是,就是按照老師的要求,寫一個程式,模擬老師的詢問。當然,老師有時候需要更新某位同學的成績。

Input

本題目包含多組測試,請處理到檔案結束。
在每個測試的第一行,有兩個正整數 N 和 M ( 0<N<=200000,0<M<5000 ),分別代表學生的數目和操作的數目。
學生ID編號分別從1編到N。
第二行包含N個整數,代表這N個學生的初始成績,其中第i個數代表ID為i的學生的成績。
接下來有M行。每一行有一個字元 C (只取'Q'或'U') ,和兩個正整數A,B。
當C為'Q'的時候,表示這是一條詢問操作,它詢問ID從A到B(包括A,B)的學生當中,成績最高的是多少。
當C為'U'的時候,表示這是一條更新操作,要求把ID為A的學生的成績更改為B。

Output

對於每一次詢問操作,在一行裡面輸出最高成績。

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output

5
6
5
9

Hint

Huge input,the C function scanf() will work better than cin

Author

linle

Source

2007省賽集訓隊練習賽(6)_linle專場

題解:線段樹基礎題,點修改+區間查詢。區間資訊為區間最大值

AC的C語言程式碼:

#include<stdio.h>
#define N 200005
#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1
//#define max(x,y) (x)>(y)?(x):(y) 使用這個超時,於是改寫成函式了 
int s[N<<2],a[N];

int max(int x,int y)
{
	return x>y?x:y;
}
//更新函式
void PushUp(int rt)
{
	s[rt]=max(s[rt<<1],s[rt<<1|1]);
} 

//建樹
void Build(int l,int r,int rt)
{
	if(l==r){
		s[rt]=a[l];
		return;
	}
	int m=(l+r)>>1;
	Build(ls);
	Build(rs);
	PushUp(rt);//更新本結點 
}

//點修改 A[L]=C
void Update(int L,int C,int l,int r,int rt)
{
	if(l==r){
		s[rt]=C;
		return;
	}
	int m=(l+r)>>1;
	if(L<=m)
	  Update(L,C,ls);
	else
	  Update(L,C,rs);
	PushUp(rt);
}
//區間查詢
int Query(int L,int R,int l,int r,int rt)
{
	if(L<=l&&r<=R)
	  return s[rt];
	int m=(l+r)>>1;
	int ans=0;
	if(L<=m)
	  ans=max(Query(L,R,ls),ans);
	if(R>m)
	  ans=max(Query(L,R,rs),ans);
	return ans;
}

int main()
{
	int n,m,i,A,B;
	while(~scanf("%d%d",&n,&m)){
		for(i=1;i<=n;i++)
		  scanf("%d",&a[i]);
		Build(1,n,1);
		while(m--){
			char c;
			scanf(" %c%d%d",&c,&A,&B);
			if(c=='Q')
			  printf("%d\n",Query(A,B,1,n,1));
			else if(c=='U')
			  Update(A,B,1,n,1);
		}
	}
	return 0;
} 
 

 

相關文章