HDU 2795 Billboard(線段樹 區間最大)

Mr_Treeeee發表於2020-04-06

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23102    Accepted Submission(s): 9554


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
3 5 5 2 4 3 3 3
 

Sample Output
1 2 1 3 -1
 

Author
hhanger@zju
 
題意:
有一塊h*w的矩形廣告牌,給你n個廣告,都是1*wi,都往儘量往左上貼,每個廣告輸出貼的排數,不能貼了就輸出-1。
POINT:
用線段樹來記錄每排空餘的最大值。優先考慮左子樹。
線段樹的區間代表第幾排。l-r代表第l排到r排。
考慮要n只有200000,那即使h特別大,我們也只要n排就行了。這個WA點看程式碼的註釋

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
const int N = 200088*8;
#define LL long long
int len[N];
int w,h,k;
void build(int x,int l,int r)
{
    if(l==r) len[x]=w;
    else
    {
        int mid=(l+r)>>1;
        build(2*x,l,mid);
        build(2*x+1,mid+1,r);
        len[x]=w;
    }
}
void put(int x,int l,int r,int a,int &flag)
{
    if(l==r)
    {
        flag=1;
        len[x]=len[x]-a;
        printf("%d\n",l);
    }
    else
    {
        int mid=(l+r)>>1;
        if(a<=len[x*2]) put(x*2,l,mid,a,flag);
        else if(a<=len[x*2+1]) put(x*2+1,mid+1,r,a,flag);
        len[x]=max(len[x*2+1],len[x*2]);
    }
}
int main()
{
    int n;
    while(~scanf("%d %d %d",&h,&w,&k))
    {
        if(h>200000)
            n=200000;//改成取h和k的最小值就會WA。
        else n=h;
        build(1,1,n);
        for(int i=1;i<=k;i++)
        {
            int a;
            scanf("%d",&a);
            int flag=0;
            put(1,1,n,a,flag);
            if(!flag) printf("-1\n");
        }
    }
}


相關文章