HDU1698 Just a Hook【線段樹基礎:區間修改+區間查詢】
Just a Hook
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 44248 Accepted Submission(s): 21158
Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.
Source
2008 “Sunline Cup” National Invitational Contest
問題連結:HDU1698 Just a Hook
題解:線段樹基礎:區間修改+區間查詢
AC的C語言程式碼:
#include<stdio.h>
#include<string.h>
#define N 100005
#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1
int sum[N<<2],add[N<<2],a[N];
//更新函式
void PushUp(int rt)
{
sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
//建樹
void Build(int l,int r,int rt)
{
if(l==r){
sum[rt]=a[l];
return;
}
int m=(l+r)>>1;
Build(ls);
Build(rs);
PushUp(rt);//更新本結點
}
//下推標記函式
void PushDown(int rt,int ln,int rn)//ln和rn分別表示rt的左右子樹的數量
{
if(add[rt]){
//下推標記
add[rt<<1]=add[rt<<1|1]=add[rt];
//修改子結點的區間資訊sum,使之與對應的add相對應
sum[rt<<1]=add[rt]*ln;
sum[rt<<1|1]=add[rt]*rn;
//清除本結點的標記
add[rt]=0;
}
}
//區間修改
void Update(int L,int R,int C,int l,int r,int rt)
{
if(L<=l&&r<=R){
sum[rt]=C*(r-l+1);//更新數字和,向上保持正確
add[rt]=C;//增加標記,表示本區間的sum正確
return;
}
int m=(l+r)>>1;
PushDown(rt,m-l+1,r-m);//下推標記
if(L<=m)
Update(L,R,C,ls);
if(R>m)
Update(L,R,C,rs);
PushUp(rt);
}
//區間查詢
int Query(int L,int R,int l,int r,int rt)
{
if(L<=l&&r<=R)
return sum[rt];
int m=(l+r)>>1;
//下推標記,否則sum可能不正確
PushDown(rt,m-l+1,r-m);
int ans=0;
if(L<=m)
ans+=Query(L,R,ls);
if(R>m)
ans+=Query(L,R,rs);
return ans;
}
int main()
{
int n,q,i,j,x,y,z,t;
scanf("%d",&t);
for(i=1;i<=t;i++){
memset(add,0,sizeof(add));//初始化標記陣列
scanf("%d%d",&n,&q);
for(j=1;j<=n;j++)
a[j]=1;
Build(1,n,1);
while(q--){
scanf("%d%d%d",&x,&y,&z);
Update(x,y,z,1,n,1);
}
printf("Case %d: The total value of the hook is %d.\n",i,Query(1,n,1,n,1));
}
return 0;
}
相關文章
- 芻議線段樹 2 (區間修改,區間查詢)
- HDU1754 I Hate It 【線段樹基礎:點修改+區間查詢】
- POJ 3468 【區間修改+區間查詢 樹狀陣列 | 線段樹 | 分塊】陣列
- HDU1166 敵兵佈陣【線段樹基礎:點修改+區間查詢】
- 線段樹(1)建樹、單點修改、單點查詢、區間查詢和例題
- 樹狀陣列的區間查詢與區間修改陣列
- 線段樹 區間乘法加法混合
- HDU 2795 Billboard(線段樹 區間最大)
- 線段樹(3)——區間操作疊加
- HDU 3397 Sequence operation(線段樹區間染色加區間合併)
- 線段樹維護單調棧——區間查詢版本 & 維護遞減序列
- 線段樹維護區間等差數列
- 日期區間查詢
- HDU 1754 I Hate It (線段樹 區間最值)
- 區間k小值(可持久化線段樹)持久化
- 樹狀陣列模板題 & (樹狀陣列 1:單點修改,區間查詢)陣列
- 關於區間操作查詢(字首和與差分)+樹狀陣列基礎陣列
- POJ 3468 A Simple Problem with Integers (線段樹 區間共加)
- HDU1166 敵兵佈陣【樹狀陣列 單點修改+區間查詢】陣列
- HDU 4027 Can you answer these queries? (線段樹 區間開方)
- 區間演算法題用線段樹可以秒解?演算法
- HDU-4348 - To the moon (主席樹+區間修改)
- HDU 1556【區間更新+單點查詢 樹狀陣列】陣列
- POJ 2528 Mayor's posters (線段樹 區間更新+離散化)
- Laravel MongoDB 時間區間查詢的問題LaravelMongoDB
- 一種期望線性的靜態區間查詢
- MySQL查詢時間段MySql
- JPA時間段查詢
- 【知識點】淺入線段樹與區間最值問題
- 【Leetcode每日一題】327. 區間和的個數(線段樹/樹狀陣列)LeetCode每日一題陣列
- linux查詢某段時間修改的檔案的總大小Linux
- 關於線段樹基礎
- 洛谷P1712 [NOI2016]區間 尺取法+線段樹+離散化
- P8868 [NOIP2022] 比賽(線段樹維護區間歷史和)
- 如何實現模糊查詢時間段
- Mysql 日期格式化 複雜日期區間查詢MySql
- 動態規劃 區間dp 基礎題動態規劃
- 數列求和【線段樹基礎】