HDU 4027 Can you answer these queries? (線段樹 區間開方)

Mr_Treeeee發表於2020-04-06

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 17354    Accepted Submission(s): 4066


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
Case #1: 19 7 6
 

Source
 
題意:
兩個操作,一個區間每個數開方和輸出區間和。

POINT:
因為開方很快就會變成1,變成1就不用開方了,所以如果區間內全是1,就剪掉這種情況。
注意這題有l>r的情況,一直被WA,也不知道作者怎麼想的,也沒特殊說明。怪我太不仔細??

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
const int N = 100060*4;
#define lt 2*x
#define rt 2*x+1
#define LL long long
LL a[N];
LL sum[N];
void build(int x,int l,int r)
{
    if(l==r) sum[x]=a[l];
    else
    {
        int mid=(l+r)>>1;
        build(lt,l,mid);
        build(rt,mid+1,r);
        sum[x]=sum[lt]+sum[rt];
    }
}
LL output(int x,int l,int r,int ll,int rr)
{
    LL ans=0;
    if(ll<=l&&rr>=r) ans+=sum[x];
    else
    {
        int mid=(l+r)>>1;
        if(ll<=mid) ans+=output(lt,l,mid,ll,rr);
        if(mid<rr) ans+=output(rt,mid+1,r,ll,rr);
    }
    return ans;
}
void srt(int x,int l,int r,int ll,int rr)
{
    if(sum[x]==r-l+1) return;
    if(l==r) sum[x]=(LL)sqrt(sum[x]);
    else
    {
        int mid=(l+r)>>1;
        if(ll<=mid) srt(lt,l,mid,ll,rr);
        if(mid<rr) srt(rt,mid+1,r,ll,rr);
        sum[x]=sum[lt]+sum[rt];
    }
}
int main()
{
    int n;
    int p=0;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
        }
        build(1,1,n);
        int q;
        scanf("%d",&q);
        printf("Case #%d:\n",++p);
        while(q--)
        {
            int k,l,r;
            scanf("%d %d %d",&k,&l,&r);
            if(l>r) swap(l,r);//這題有l比r大的情況,真是要死了。
            if(k)
            {
                LL ans=output(1,1,n,l,r);
                printf("%lld\n",ans);
            }
            else
            {
                srt(1,1,n,l,r);
            }
        }
        printf("\n");//每個樣例後有空行。
        
    }
}


相關文章