HDU 4027 Can you answer these queries? (線段樹 區間開方)
Can you answer these queries?
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)Total Submission(s): 17354 Accepted Submission(s): 4066
Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease
the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for
help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.
Notice that the square root operation should be rounded down to integer.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.
Notice that the square root operation should be rounded down to integer.
Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8
Sample Output
Case #1:
19
7
6
Source
題意:
兩個操作,一個區間每個數開方和輸出區間和。
POINT:
因為開方很快就會變成1,變成1就不用開方了,所以如果區間內全是1,就剪掉這種情況。
注意這題有l>r的情況,一直被WA,也不知道作者怎麼想的,也沒特殊說明。怪我太不仔細??
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
const int N = 100060*4;
#define lt 2*x
#define rt 2*x+1
#define LL long long
LL a[N];
LL sum[N];
void build(int x,int l,int r)
{
if(l==r) sum[x]=a[l];
else
{
int mid=(l+r)>>1;
build(lt,l,mid);
build(rt,mid+1,r);
sum[x]=sum[lt]+sum[rt];
}
}
LL output(int x,int l,int r,int ll,int rr)
{
LL ans=0;
if(ll<=l&&rr>=r) ans+=sum[x];
else
{
int mid=(l+r)>>1;
if(ll<=mid) ans+=output(lt,l,mid,ll,rr);
if(mid<rr) ans+=output(rt,mid+1,r,ll,rr);
}
return ans;
}
void srt(int x,int l,int r,int ll,int rr)
{
if(sum[x]==r-l+1) return;
if(l==r) sum[x]=(LL)sqrt(sum[x]);
else
{
int mid=(l+r)>>1;
if(ll<=mid) srt(lt,l,mid,ll,rr);
if(mid<rr) srt(rt,mid+1,r,ll,rr);
sum[x]=sum[lt]+sum[rt];
}
}
int main()
{
int n;
int p=0;
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)
{
scanf("%lld",&a[i]);
}
build(1,1,n);
int q;
scanf("%d",&q);
printf("Case #%d:\n",++p);
while(q--)
{
int k,l,r;
scanf("%d %d %d",&k,&l,&r);
if(l>r) swap(l,r);//這題有l比r大的情況,真是要死了。
if(k)
{
LL ans=output(1,1,n,l,r);
printf("%lld\n",ans);
}
else
{
srt(1,1,n,l,r);
}
}
printf("\n");//每個樣例後有空行。
}
}
相關文章
- HDU 2795 Billboard(線段樹 區間最大)
- HDU 1754 I Hate It (線段樹 區間最值)
- HDU 3397 Sequence operation(線段樹區間染色加區間合併)
- HDU1698 Just a Hook【線段樹基礎:區間修改+區間查詢】Hook
- 線段樹 transformation——hdu 4578ORM
- HDU1754 I Hate It 【線段樹基礎:點修改+區間查詢】
- CodeForces 145 E. Lucky Queries(線段樹)
- 線段樹 區間乘法加法混合
- hdu 1698 線段樹 一段更新染色
- HDU1166 敵兵佈陣【線段樹基礎:點修改+區間查詢】
- Codeforces Round #675 (Div. 2) 1442 F - Boring Queries 可持久化線段樹維護 區間乘法持久化
- 線段樹(3)——區間操作疊加
- HDU 3333 Turing Tree(線段樹+離線操作)
- 芻議線段樹 2 (區間修改,區間查詢)
- HDU 1556 Color the ball(線段樹|樹狀陣列)陣列
- HDU 1394 Minimum Inversion Number (暴力+線段樹)
- Transformation HDU - 4578線段樹綜合操作ORM
- 線段樹維護區間等差數列
- POJ 3468 【區間修改+區間查詢 樹狀陣列 | 線段樹 | 分塊】陣列
- HDU 3074 Multiply game(線段樹 單點更新)GAM
- HDU 1542 Atlantis (線段樹+離散化+掃描線)
- 區間k小值(可持久化線段樹)持久化
- HDU-4348 - To the moon (主席樹+區間修改)
- HDU 1166 敵兵佈陣 (線段樹 插點問線)
- POJ 3468 A Simple Problem with Integers (線段樹 區間共加)
- P4145 上帝造題的七分鐘2 / 花神遊歷各國 (線段樹區間開方)
- 區間演算法題用線段樹可以秒解?演算法
- POJ 2528 Mayor's posters (線段樹 區間更新+離散化)
- why you can be in netherland
- HDU 1255 覆蓋的面積(線段樹+掃描線+離散化)
- 【知識點】淺入線段樹與區間最值問題
- 【Leetcode每日一題】327. 區間和的個數(線段樹/樹狀陣列)LeetCode每日一題陣列
- 動態開點線段樹
- 線段樹從零開始
- 線段樹
- 線~段~樹
- HDU 1556【區間更新+單點查詢 樹狀陣列】陣列
- 線段樹(1)建樹、單點修改、單點查詢、區間查詢和例題