POJ 3468 A Simple Problem with Integers (線段樹 區間共加)
Time Limit: 5000MS | Memory Limit: 131072K | |
Total Submissions: 112230 | Accepted: 34906 | |
Case Time Limit: 2000MS |
Description
You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.
Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.
Output
You need to answer all Q commands in order. One answer in a line.
Sample Input
10 5 1 2 3 4 5 6 7 8 9 10 Q 4 4 Q 1 10 Q 2 4 C 3 6 3 Q 2 4
Sample Output
4 55 9 15
Hint
Source
POJ Monthly--2007.11.25, Yang Yi
線段樹的區間更改,求區間和。
注意用ll,資料超int
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
const int N = 100440*8;
#define LL long long
LL sum[N],add[N];
LL a[N/5];
void build(int x,int l,int r)
{
if(l==r) sum[x]=a[l];
else
{
int mid=(l+r)>>1;
build(2*x,l,mid);
build(2*x+1,mid+1,r);
sum[x]=sum[x*2]+sum[x*2+1];
}
}
void pushdown(int x,int l,int r)
{
int mid=(l+r)>>1;
add[2*x]+=add[x];
sum[2*x]+=(LL)(mid-l+1)*add[x];
add[2*x+1]+=add[x];
sum[2*x+1]+=(LL)(r-mid)*add[x];
add[x]=0;
}
void Add(int x,int l,int r,int ll,int rr,LL c)
{
if(add[x]!=0) pushdown(x,l,r);
if(ll<=l&&rr>=r)
{
sum[x]+=(LL)(r-l+1)*c;
add[x]+=(LL)c;
}
else
{
int mid=(l+r)>>1;
if(ll<=mid) Add(2*x,l,mid,ll,rr,c);
if(mid<rr) Add(2*x+1,mid+1,r,ll,rr,c);
sum[x]=sum[x*2]+sum[x*2+1];
}
}
LL query(int x,int l,int r,int ll,int rr)
{
if(add[x]!=0) pushdown(x,l,r);
LL ans=0;
if(ll<=l&&rr>=r) ans+=sum[x];
else
{
int mid=(l+r)>>1;
if(ll<=mid) ans+=query(2*x,l,mid,ll,rr);
if(mid<rr) ans+=query(2*x+1,mid+1,r,ll,rr);
}
return ans;
}
int main()
{
int n,q;
while(~scanf("%d %d",&n,&q))
{
memset(add,0,sizeof add);
for(int i=1;i<=n;i++)
{
scanf("%lld",&a[i]);
}
build(1,1,n);
while(q--)
{
char s;
getchar();
scanf("%c",&s);
if(s=='C')
{
int l,r;
LL c;
scanf("%d %d %lld",&l,&r,&c);
Add(1,1,n,l,r,c);
// for(int i=1;i<=n;i++)
// {
// printf("%lld ",query(1,1,n,i,i));
// }
// printf("\n");
}
else
{
int l,r;
scanf("%d %d",&l,&r);
LL ans=query(1,1,n,l,r);
printf("%lld\n",ans);
}
}
}
}
相關文章
- 【poj3468】A Simple Problem with Integers
- POJ3468 A Simple Problem with Integers---樹狀陣列(區間問題)陣列
- bzoj3212: Pku3468 A Simple Problem with Integers(線段樹)
- POJ 3468 【區間修改+區間查詢 樹狀陣列 | 線段樹 | 分塊】陣列
- NC17383 A Simple Problem with Integers
- 線段樹(3)——區間操作疊加
- POJ 2528 Mayor's posters (線段樹 區間更新+離散化)
- HDU 3397 Sequence operation(線段樹區間染色加區間合併)
- POJ 3667 Hotel 線段樹
- poj 2667 hotel 線段樹
- 線段樹 區間乘法加法混合
- HDU 2795 Billboard(線段樹 區間最大)
- 芻議線段樹 2 (區間修改,區間查詢)
- 線段樹維護區間等差數列
- HDU 1754 I Hate It (線段樹 區間最值)
- 區間k小值(可持久化線段樹)持久化
- POJ 2777 Count Color (線段樹+狀態壓縮)
- A - Yet Another Two Integers Problem ACMACM
- TZOJ 8472 : Tree (重鏈剖分+線段樹) POJ 3237
- HDU1698 Just a Hook【線段樹基礎:區間修改+區間查詢】Hook
- POJ 2891 Strange Way to Express IntegersExpress
- HDU 4027 Can you answer these queries? (線段樹 區間開方)
- 區間演算法題用線段樹可以秒解?演算法
- POJ 2355 Railway Ticket problemAI
- 【知識點】淺入線段樹與區間最值問題
- 【Leetcode每日一題】327. 區間和的個數(線段樹/樹狀陣列)LeetCode每日一題陣列
- 線~段~樹
- 線段樹
- HDU1754 I Hate It 【線段樹基礎:點修改+區間查詢】
- 一些線段樹典(求求了區域賽遇到線段樹不要被卡了)
- 線段樹(1)建樹、單點修改、單點查詢、區間查詢和例題
- 線段樹模板
- 線段樹--RMQMQ
- 01 線段樹
- 線段樹 hate it
- 【模版】線段樹
- POJ1390 Blocks (區間DP)BloC
- HDU1166 敵兵佈陣【線段樹基礎:點修改+區間查詢】