POJ 3468 A Simple Problem with Integers (線段樹 區間共加)

Mr_Treeeee發表於2020-04-06
A Simple Problem with Integers
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 112230   Accepted: 34906
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi


線段樹的區間更改,求區間和。

注意用ll,資料超int


#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
const int N = 100440*8;
#define LL long long
LL sum[N],add[N];
LL a[N/5];
void build(int x,int l,int r)
{
    if(l==r) sum[x]=a[l];
    else
    {
        int mid=(l+r)>>1;
        build(2*x,l,mid);
        build(2*x+1,mid+1,r);
        sum[x]=sum[x*2]+sum[x*2+1];
    }
}
void pushdown(int x,int l,int r)
{
    int mid=(l+r)>>1;
    add[2*x]+=add[x];
    sum[2*x]+=(LL)(mid-l+1)*add[x];
    add[2*x+1]+=add[x];
    sum[2*x+1]+=(LL)(r-mid)*add[x];
    add[x]=0;
}
void Add(int x,int l,int r,int ll,int rr,LL c)
{
    if(add[x]!=0) pushdown(x,l,r);
    if(ll<=l&&rr>=r)
    {
        sum[x]+=(LL)(r-l+1)*c;
        add[x]+=(LL)c;
    }
    else
    {
        int mid=(l+r)>>1;
        if(ll<=mid) Add(2*x,l,mid,ll,rr,c);
        if(mid<rr) Add(2*x+1,mid+1,r,ll,rr,c);
        sum[x]=sum[x*2]+sum[x*2+1];
    }
    
}
LL query(int x,int l,int r,int ll,int rr)
{
    if(add[x]!=0) pushdown(x,l,r);
    LL ans=0;
    if(ll<=l&&rr>=r) ans+=sum[x];
    else
    {
        int mid=(l+r)>>1;
        if(ll<=mid) ans+=query(2*x,l,mid,ll,rr);
        if(mid<rr) ans+=query(2*x+1,mid+1,r,ll,rr);
    }
    return ans;
}
int main()
{
    int n,q;
    while(~scanf("%d %d",&n,&q))
    {
        memset(add,0,sizeof add);
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
        }
        build(1,1,n);
        while(q--)
        {
            char s;
            getchar();
            scanf("%c",&s);
            if(s=='C')
            {
                int l,r;
                LL c;
                scanf("%d %d %lld",&l,&r,&c);
                Add(1,1,n,l,r,c);
//                for(int i=1;i<=n;i++)
//                {
//                    printf("%lld ",query(1,1,n,i,i));
//                }
//                printf("\n");
            }
            else
            {
                int l,r;
                scanf("%d %d",&l,&r);
                LL ans=query(1,1,n,l,r);
                printf("%lld\n",ans);
            }
        }
    }
}



相關文章