HDU 2689 【歸併排序求逆序對】

神探小小迪發表於2018-09-26

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need. 
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4. 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

Output

For each case, output the minimum times need to sort it in ascending order on a single line.

Sample Input

3
1 2 3
4 
4 3 2 1 

Sample Output

0
6

題解:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 1005;
int n, ans;
int a[maxn], b[maxn];

void Merge_Sort(int l, int r){
    if(l < r){
        int mid = (l+r) / 2;
        int i = l, j = mid+1, id = l;
        Merge_Sort(l, mid);
        Merge_Sort(mid+1, r);
        while(i <= mid && j <= r){
            if(a[i] <= a[j]) b[id++] = a[i++];
            else b[id++] = a[j++], ans += mid - i + 1;//a[i~mid]都比a[j]要打,所以產生mid-i+1個逆序對
        }
        while(i <= mid) b[id++] = a[i++];
        while(j <= r) b[id++] = a[j++];
        for(int k = l; k <= r; k++) a[k] = b[k];
    }
}
int main()
{
    while(~scanf("%d", &n)){
        ans = 0;
        memset(b, 0, sizeof b);
        memset(a, 0, sizeof a);
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        Merge_Sort(1, n);
        printf("%d\n", ans);
    }
    return 0;
}

 

相關文章