HDU 2689 【歸併排序求逆序對】
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
Output
For each case, output the minimum times need to sort it in ascending order on a single line.
Sample Input
3 1 2 3 4 4 3 2 1
Sample Output
0 6
題解:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 1005;
int n, ans;
int a[maxn], b[maxn];
void Merge_Sort(int l, int r){
if(l < r){
int mid = (l+r) / 2;
int i = l, j = mid+1, id = l;
Merge_Sort(l, mid);
Merge_Sort(mid+1, r);
while(i <= mid && j <= r){
if(a[i] <= a[j]) b[id++] = a[i++];
else b[id++] = a[j++], ans += mid - i + 1;//a[i~mid]都比a[j]要打,所以產生mid-i+1個逆序對
}
while(i <= mid) b[id++] = a[i++];
while(j <= r) b[id++] = a[j++];
for(int k = l; k <= r; k++) a[k] = b[k];
}
}
int main()
{
while(~scanf("%d", &n)){
ans = 0;
memset(b, 0, sizeof b);
memset(a, 0, sizeof a);
for(int i = 1; i <= n; i++)
scanf("%d", &a[i]);
Merge_Sort(1, n);
printf("%d\n", ans);
}
return 0;
}
相關文章
- HDU 4911 Inversion(歸併排序求逆序數)排序
- HDU 2689 Sort it【樹狀陣列求逆序對】陣列
- 歸併排序的經典-求逆序對排序
- 歸併排序求逆序數排序
- 歸併排序思想應用之----求陣列中的逆序對排序陣列
- HDU2689 Sort it (樹狀陣列求逆序數)陣列
- 逆序對的數量(歸併排序模板)排序
- 歸併排序-陣列中的逆序對排序陣列
- 進階指南--超快速排序(歸併+逆序對)排序
- 藍橋杯 小朋友排隊 (歸併排序 逆序數 好題)排序
- [排序] 歸併排序排序
- 歸併排序排序
- 快速排序&&歸併排序排序
- HDU 3600 Simple Puzzle 歸併排序 N*N數碼問題排序
- 四、歸併排序 && 快速排序排序
- java歸併排序Java排序
- [java]歸併排序Java排序
- 歸併排序模板排序
- 歸併排序--二路排序排序
- 排序演算法__歸併排序排序演算法
- 排序演算法:歸併排序排序演算法
- 歸併排序和基數排序排序
- 歸併排序--排序演算法排序演算法
- 排序演算法 - 歸併排序排序演算法
- 排序演算法——歸併排序排序演算法
- 排序演算法(歸併排序)排序演算法
- 歸併排序 js demo排序JS
- C# 歸併排序C#排序
- 【筆記】歸併排序筆記排序
- 歸併排序例項排序
- 歸併排序與快速排序的簡明實現及對比排序
- HDU 1394 Minimum Inversion Number (樹狀陣列求逆序數)陣列
- 排序演算法之 '歸併排序'排序演算法
- php實現 歸併排序,快速排序PHP排序
- php插入排序,快速排序,歸併排序,堆排序PHP排序
- go 實現歸併排序Go排序
- 歸併排序——C語言排序C語言
- 歸併排序 nO(lgn) 稽核中排序