HDU 2509 Be the Winner (尼姆博弈)

Mr_Treeeee發表於2020-04-06

Be the Winner

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3692    Accepted Submission(s): 2062


Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is 
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
 

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
 

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
 

Sample Input
2 2 2 1 3
 

Sample Output
No Yes
 

Source

ECJTU 2008 Autumn Contest


題意:

其他與尼姆博弈相同,但它不能取則輸。


POINT:

分單堆和多堆討論。若沒有多堆,則看單堆數量奇偶。若有多堆,異或為0則後手贏,反之先手贏。


#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
using namespace std;
#define  ll long long

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int res=0;
        
        int t=0;
        while(n--)
        {
            int a;
            scanf("%d",&a);
            if(a!=1) t++;
            res=res^a;
        }
        if(res==0&&t==0) printf("Yes\n");//T0態	無多堆,單堆是偶
        else if(res==1&&t==0) printf("No\n");//S0態 無多堆,單堆是奇
        else if(res!=0) printf("Yes\n");//S2 S1 //有多堆,異或非0
        else printf("No\n");
    }
}