HDU 2509 Be the Winner (尼姆博弈)
Be the Winner
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3692 Accepted Submission(s): 2062
Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
Sample Input
2
2 2
1
3
Sample Output
No
Yes
Source
題意:
其他與尼姆博弈相同,但它不能取則輸。
POINT:
分單堆和多堆討論。若沒有多堆,則看單堆數量奇偶。若有多堆,異或為0則後手贏,反之先手贏。
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
using namespace std;
#define ll long long
int main()
{
int n;
while(~scanf("%d",&n))
{
int res=0;
int t=0;
while(n--)
{
int a;
scanf("%d",&a);
if(a!=1) t++;
res=res^a;
}
if(res==0&&t==0) printf("Yes\n");//T0態 無多堆,單堆是偶
else if(res==1&&t==0) printf("No\n");//S0態 無多堆,單堆是奇
else if(res!=0) printf("Yes\n");//S2 S1 //有多堆,異或非0
else printf("No\n");
}
}
相關文章
- HDU 1848 Fibonacci again and again (尼姆博弈+sg函式)AI函式
- 【博弈論】HDU - 7216 Triangle GameGAM
- hdu2516 斐波納契博弈
- leetcode 486. Predict the WinnerLeetCode
- Winner許可權管理系統3.0
- 博弈論系列—智豬博弈
- 51nod1548 歐姆諾姆和糖果
- 博弈論
- 尼爾·布洛姆坎普專訪:談轉行遊戲與對遊戲業未來的看法遊戲
- hdu 2111 Saving HDU (DP)
- 博弈論合集
- 巴什博弈
- 智豬博弈
- 博弈論專練
- 博弈論入門
- 博弈論總結
- 博弈論小記
- 博弈論詳解
- Shape of HDU
- HDU 3349
- HDU 2052(C語言+註釋)+HDU 2090C語言
- 博弈論(長期更新)
- 博弈補充練習
- 四種博弈總結
- 簡單的揹包問題(入門)HDU2602 HDU2546 HDU1864
- HDU 1240 Asteroids!AST
- hdu2083
- hdu5532
- HDU4787
- hdu5540
- HDU 4921 Map
- HDU 3661 Assignments
- hdu 6415 - DP
- AI先驅者丹尼爾·丹尼特去世AI
- 遊戲博弈論研究:最優解策略與混合迴圈戰略博弈遊戲
- 普里姆(Prim)演算法演算法
- 博弈論題目選做
- 科技超車,vivo博弈論