hdu5540

Zixuan Dada~發表於2020-10-15

Secrete Master Plan

Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, when Fei opened the pocket he found there are only four numbers written in dots on a piece of sheet. The numbers form 2×2
matrix, but Fei didn’t know the correct direction to hold the sheet. What a pity!
Given two secrete master plans. The first one is the master’s original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might give Fei the wrong pocket. Determine if Fei receives the right pocket.
在這裡插入圖片描述

Input
The first line of the input gives the number of test cases,
T(1≤T≤104). Ttest cases follow. Each test case contains 4 lines. Each line contains two integers
ai0 and ai1(1≤ai0,ai1≤100). The first two lines stands for the original plan, the 3rdand 4th line stands for the plan Fei opened.

Output
For each test case, output one line containing “Case #x: y”, where x is the test case number
(starting from 1) and y is either “POSSIBLE” or “IMPOSSIBLE” (quotes for clarity).

Sample Input
4
1 2
3 4
1 2
3 4

1 2
3 4
3 1
4 2

1 2
3 4
3 2
4 1

1 2
3 4
4 3
2 1

Sample Output
Case #1: POSSIBLE
Case #2: POSSIBLE
Case #3: IMPOSSIBLE
Case #4: POSSIBLE

Source
The 2015 China Collegiate Programming Contest

題意:

將資料按0度,90度,180度,270度旋轉後各資料
能進行相對應的匹配即可,
由於本題只要求輸入2x2的資料,直接定義8個變數存兩組資料即可.

AC程式碼

#include"iostream"
using namespace std;
int main()
{
	int t;
	int num=1;
	int x1,x2,x3,x4,y1,y2,y3,y4;
	cin>>t;
	while(t--)
	{
		cin>>x1>>x2>>x4>>x3;//注意輸入:先輸入x4再輸入x3
		cin>>y1>>y2>>y4>>y3;//同上,這樣才有順序!
		if(x1==y1&&x2==y2&&x3==y3&&x4==y4)
			cout<<"Case #"<<num<<": POSSIBLE"<<endl;
		else if(x1==y2&&x2==y3&&x3==y4&&x4==y1)
			cout<<"Case #"<<num<<": POSSIBLE"<<endl;
		else if(x1==y3&&x2==y4&&x3==y1&&x4==y2)
			cout<<"Case #"<<num<<": POSSIBLE"<<endl;
		else if(x1==y4&&x2==y1&&x3==y2&&x4==y3)
			cout<<"Case #"<<num<<": POSSIBLE"<<endl;
		else
			cout<<"Case #"<<num<<": IMPOSSIBLE"<<endl;
		num++;
	}
}