HDU 3349
lazy gege
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1391 Accepted Submission(s): 586
Problem Description
Gege hasn’t tidied his desk for long,now his desk is full of things.
This morning Gege bought a notebook,while to find somewhise to put it troubles him.
He wants to tidy a small area of the desk, leaving an empty area, and put the notebook there, the notebook shouldn’t fall off the desk when putting there.
The desk is a square and the notebook is a rectangle, area of the desk may be smaller than the notebook.
here’re two possible conditions:
Can you tell Gege the smallest area he must tidy to put his notebook?
Input
T(T<=100) in the first line is the case number.
The next T lines each has 3 real numbers, L,A,B(0< L,A,B <= 1000).
L is the side length of the square desk.
A,B is length and width of the rectangle notebook.
Output
For each case, output a real number with 4 decimal(printf(“%.4lf”,ans) is OK), indicating the smallest area Gege should tidy.
Sample Input
3
10.1 20 10
3.0 20 10
30.5 20.4 19.6
Sample Output
25.0000
9.0000
96.0400
題解:
為了將書放在桌子上並儘可能小的佔用空間,當重心放在上面即可;
沿著桌子的稜角去放書,三種情況:
1:
2:
3:
程式碼:
#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
int T;
cin >>T;
while(T--){
double L,A,B;
cin >> L >>A >> B;
double x;
x=L/sqrt(2);
double Min;
Min=min(A,B);
double s;
if(x>=Min/2) {
s=Min*Min/4;
}
else if(x*2<=Min/2){
s=L*L;
}
else {
s=L*L-(sqrt(2)*L-Min/2)*(sqrt(2)*L-Min/2);
}
printf("%.4f\n",s);
}
return 0;
}
相關文章
- P3349 [ZJOI2016] 小星星
- hdu 2111 Saving HDU (DP)
- Shape of HDU
- HDU 2052(C語言+註釋)+HDU 2090C語言
- 簡單的揹包問題(入門)HDU2602 HDU2546 HDU1864
- HDU 1240 Asteroids!AST
- hdu2083
- hdu5532
- HDU4787
- hdu5540
- HDU 4921 Map
- HDU 3661 Assignments
- hdu 6415 - DP
- HDU 1729 Stone GameGAM
- HDU 3590 PP and QQ
- HDU 2570 迷瘴
- hdu1069javaJava
- hdu1025javaJava
- HDU Find the hotel(RMQ)MQ
- HDU 6060 RXD and dividing
- Switch Game HDU - 2053GAM
- HDU1024(dp)
- HDU - 6182 A Math Problem
- hdu2011javaJava
- HDU 2612 Find a way
- HDU6415(DP)
- HDU 3400 Line belt
- HDU 1236 排名(Java)Java
- hdu 4370(最短路)
- HDU 不要62 題解
- hdu2600 C++C++
- hdu 1232通暢工程
- hdu1195 Open the Lock
- HDU 1711 Number Sequence(KMP)KMP
- HDU 3183 A Magic Lamp (RMQ)LAMPMQ
- HDU 5821 Ball(貪心)
- HDU 4858 專案管理專案管理
- HDU - 6736 F - Forest ProgramREST