HDU 1236 排名(Java)

Cymbals發表於2018-03-14

今天的上機考試雖然有實時的Ranklist,但上面的排名只是根據完成的題數排序,沒有考慮
每題的分值,所以並不是最後的排名。給定錄取分數線,請你寫程式找出最後通過分數線的
考生,並將他們的成績按降序列印。
Input
測試輸入包含若干場考試的資訊。每場考試資訊的第1行給出考生人數N ( 0 < N
< 1000 )、考題數M ( 0 < M < = 10 )、分數線(正整數)G;第2行排序給出第1題至第M題的正整數分值;以下N行,每行給出一
名考生的准考證號(長度不超過20的字串)、該生解決的題目總數m、以及這m道題的題號
(題目號由1到M)。
當讀入的考生人數為0時,輸入結束,該場考試不予處理。
Output
對每場考試,首先在第1行輸出不低於分數線的考生人數n,隨後n行按分數從高
到低輸出上線考生的考號與分數,其間用1空格分隔。若有多名考生分數相同,則按他們考
號的升序輸出。
Sample Input
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0
Sample Output
3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

這題有坑啊…..不涉及演算法,很簡單的類排序,寫好compare就能ac。

坑點在於題目說的是分數相同“按考號排序”,沒有清楚的告訴你到底怎麼排,實際上他的輸入裡肯定有“CS000000001”和“CS001”這兩種情況同時出現讓你比較,要是直接擷取字串轉成int就gg了,因為int不存字首0。

所以就必須想辦法保留字首零。這裡用Java有兩種方法可以考慮進字首零,一種是用String.valueOf,把CS後面的數字丟進去,“001”會好好的返回001(Integer.praseInt會返回1)。這是我隊友的做法,我的做法是用hashCode來比較。兩種都能ac。

ac程式碼:

public class Main {
    static int[] score = new int[15];

    public static void main(String[] args) {
        Scanner reader = new Scanner(System.in);
        //InputReader reader = new InputReader();
        int n = reader.nextInt();
        PriorityQueue<Joiner> wait = new PriorityQueue<Joiner>();
        while (n != 0) {
            int m = reader.nextInt();// 人數
            int g = reader.nextInt();// 分數線
            for (int i = 1; i <= m; i++) {
                score[i] = reader.nextInt();
            }
            int count = 0;
            for (int i = 0; i < n; i++) {
                String name = reader.next();
                int solved = reader.nextInt();
                int sum = 0;
                for (int j = 0; j < solved; j++) {
                    sum += score[reader.nextInt()];
                }
                if (sum >= g) {
                    count++;
                    wait.add(new Joiner(name, sum));
                }
            }
            System.out.println(count);
            while (!wait.isEmpty()) {
                Joiner get = wait.poll();
                System.out.println(get.name + " " + get.sum);
            }
            n = reader.nextInt();
        }
    }
}

class Joiner implements Comparable<Joiner> {
    String name;
    String id;
    int sum;

    public Joiner(String name, int sum) {
        this.name = name;
        this.id = name.substring(2, name.length());
        this.sum = sum;
    }

    @Override
    public int compareTo(Joiner o) {
        if (this.sum > o.sum) {
            return -1;
        } else if (this.sum < o.sum) {
            return 1;
        }
        if (this.id.hashCode() > o.id.hashCode()) {
            return 1;
        } else if (this.id.hashCode() < o.id.hashCode()) {
            return -1;
        }
        return 0;
    }
}

相關文章