hdu 5147 樹狀陣列

life4711發表於2014-12-21

http://acm.hdu.edu.cn/showproblem.php?pid=5147

Problem Description
Long long ago, there is a sequence A with length n. All numbers in this sequence is no smaller than 1 and no bigger than n, and all numbers are different in this sequence.
Please calculate how many quad (a,b,c,d) satisfy:
1. 1a<b<c<dn
2. Aa<Ab
3. Ac<Ad
 

Input
The first line contains a single integer T, indicating the number of test cases.
Each test case begins with a line contains an integer n.
The next line follows n integers A1,A2,,An.

[Technical Specification]
1 <= T <= 100
1 <= n <= 50000
1 <= Ai <= n
 

Output
For each case output one line contains a integer,the number of quad.
 

Sample Input
1 5 1 3 2 4 5
 

Sample Output
4
/**
hdu5147 樹狀陣列
解題思路:
        要統計四元組的數量我們可以通過列舉c,然後統計區間[1,c-1]有多少二元組(a,b)滿足a<b且Aa<Ab,以及統計出區間[c+1,n]有多少d滿足Ac<Ad,
根據乘法原理,把這兩項乘起來就可以統計到答案裡了.然後我們來處理子問題:區間[1,c-1]內有多少二元組(a,b).那麼我們可以列舉b,然後統計
區間[1,b-1]內有多少a滿足Aa<Ab,那麼這個可以通過用樹狀陣列詢問字首和來實現.

具體實現:b[i]和c[i]中儲存的分別為以i結尾的Ax<Ay的對數和從i+1到n中Ax<Ay的對數,二者相乘即為答案。
時間複雜度是O(nlogn).
*/
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
typedef long long LL;

int C[100005],b[100005],c[100005],a[100005];
int n;

int lowbit(int x)
{
    return x&(-x);
}
int sum(int x)
{
    int ret=0;
    while(x>0)
    {
        ret+=C[x];
        x-=lowbit(x);
    }
    return ret;
}
void add(int x,int d)
{
    while(x<=n)
    {
        C[x]+=d;
        x+=lowbit(x);
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        memset(C,0,sizeof(C));
        for(int i=1;i<=n;i++)
        {
            b[i]=sum(a[i]);
            add(a[i],1);
        }
        memset(C,0,sizeof(C));
        for(int i=n;i>=1;i--)
        {
            c[i]=sum(n)-sum(a[i])+c[i+1];
            add(a[i],1);
        }
        LL ans=0;
        for(int i=2;i<=n-2;i++)
        {
            LL t1=b[i];
            LL t2=c[i+1];
            ans+=t1*t2;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


相關文章