杭電ACM hdu 1398 Square Coins 解題報告(母函式)
Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers
up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:
ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.
Your mission is to count the number of ways to pay a given amount using coins of Silverland.
Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
Sample Input
2
10
30
0
Sample Output
1
4
27
Source
Asia 1999, Kyoto (Japan)
Recommend
Ignatius.L
Solution
以下部分的版權歸本人(小飛)所有。所有權利保留。
歡迎轉載,轉載時請註明出處:
http://blog.csdn.net/xiaofei_it/article/details/17041815
本題直接套用母函式模板即可。關於母函式的詳細解釋請看:
http://blog.csdn.net/xiaofei_it/article/details/17042651
程式碼如下:
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 301
int n,a[MAX],b[MAX],i,j,k,v[18];
int main()
{
for (i=1;i<=17;i++)
v[i]=i*i;
while ((cin>>n)&&n>0)
{
memset(a,0,sizeof(a));
a[0]=1;
for (i=1;i<=17;i++)
{
memset(b,0,sizeof(b));
for (j=0;j*v[i]<=n;j++)
for (k=0;k+j*v[i]<=n;k++)
b[k+j*v[i]]+=a[k];
memcpy(a,b,sizeof(b));
}
cout<<a[n]<<endl;
}
return 0;
}
相關文章
- HDU 母函式簡單題 - 找單詞/Ignatius and the Princess III/Square Coins/Holding Bin-Laden Captive!函式APT
- HDU 1709 The Balance(母函式)函式
- 杭電OJ1040解題報告
- 杭電hdu2072
- 杭電HDU2018 奶牛的故事
- [Atcoder DP I]Coins 題解
- 「SWTR-4」Collecting Coins 題解
- (補題 杭電 1008)Elevator
- 杭電多校補題
- HDU-ACM 2024 Day3ACM
- HDU-ACM 2024 Day4ACM
- HDU-ACM 2024 Day2ACM
- 2020-10-30 ACM實踐報告部分程式題ACM
- HDU 1848 Fibonacci again and again(SG函式)AI函式
- HDU 不要62 題解
- HDU - 5879解題文件
- 杭電2046
- 例題 7-15 破壞正方形(Square Destyoyer,ACM/ICPC Taejon 2001,UVa1603)ACM
- 清科觀察:2018年母基金報告
- 杭電oj 2020
- 杭電No2000
- 2019山東ACM省賽補題題解ACM
- 【記憶優化搜尋/dp】HDU - 6415 - 杭電多校第九場 - Rikka with Nash Equilibrium優化UI
- HDU 6311 - Cover [2018杭電多校聯賽第二場 C](尤拉通路/迴路)
- HDU 1848 Fibonacci again and again (尼姆博弈+sg函式)AI函式
- [熵值] 解題報告熵
- 杭電2048(遞推)
- (杭電1406)完數
- 『杭電1810』Rating of Tetris
- 『杭電1940』ICPC Scoreboard
- 『杭電1939』He is offside!IDE
- 『杭電1937』Finding Seats
- HDU 5795 A Simple Nim (SG函式+打表找規律)函式
- HDU100題簡要題解(2080~2089)
- [題解]AT_abc299_f [ABC299F] Square Subsequence
- ARC173 解題報告
- P11188 解題報告
- SP30906 解題報告
- P10499 解題報告