HDU 1709 The Balance(母函式)
The Balance
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 8192 Accepted Submission(s): 3430
Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
Sample Input
3
1 2 4
3
9 2 1
Sample Output
0
2
4 5
Source
題意:
給你幾個砝碼,一個天平,求出不能稱出的重量,砝碼可以左右放。
POINT:
母函式,其實感覺就是個DP而已。天平可以放兩邊就是減一下。
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <map>
using namespace std;
#define LL long long
const int N = 12000+6;
int c1[N],c2[N];
int a[N];
int main()
{
int n;
while(~scanf("%d",&n))
{
int sum=0;
for(int i=1;i<=n;i++)
scanf("%d",&a[i]),sum+=a[i];
memset(c1,0,sizeof c1);
c1[0]=c1[a[1]]=1;
for(int i=2;i<=n;i++)
{
for(int j=sum;j>=0;j--)
{
if(c1[j]==1)
{
c2[j]=1;
c2[j+a[i]]=1;
c2[abs(j-a[i])]=1;
}
}
for(int j=0;j<=sum;j++) c1[j]=c2[j],c2[j]=0;
}
int cnt=0;
int ans[N];
for(int i=1;i<=sum;i++)
{
if(c1[i]==0)
{
ans[++cnt]=i;
}
}
if(cnt==0) printf("0\n");
else
{
printf("%d\n",cnt);
for(int i=1;i<=cnt;i++)
{
if(!(i-1)) printf("%d",ans[i]);
else printf(" %d",ans[i]);
}
printf("\n");
}
}
return 0;
}
相關文章
- HDU 母函式簡單題 - 找單詞/Ignatius and the Princess III/Square Coins/Holding Bin-Laden Captive!函式APT
- HDU 1848 Fibonacci again and again(SG函式)AI函式
- HDU 1848 Fibonacci again and again (尼姆博弈+sg函式)AI函式
- HDU 5795 A Simple Nim (SG函式+打表找規律)函式
- MySQL函式大全(字串函式,數學函式,日期函式,系統級函式,聚合函式)MySql函式字串
- python中id()函式、zip()函式、map()函式、lamda函式Python函式
- Python 擴充之特殊函式(lambda 函式,map 函式,filter 函式,reduce 函式)Python函式Filter
- 邊學邊寫——母函式及其在中學數學競賽中的運用(一)函式
- [CSS] text-wrap: balanceCSS
- HDFS balance策略詳解
- 第7章 IF函式 COUNTIF函式 SUMIF函式函式
- MySQL(四)日期函式 NULL函式 字串函式MySql函式Null字串
- (譯) 函式式 JS #2: 函式!函式JS
- 核函式 多項式核函式 高斯核函式(常用)函式
- 第 8 節:函式-匿名函式、遞迴函式函式遞迴
- lambda匿名函式sorted排序函式filter過濾函式map對映函式函式排序Filter
- main函式的入口函式AI函式
- SQL-函式 - 聚合函式SQL函式
- 【每日函式】每日函式(2021.08.16)函式
- 【每日函式】每日函式(2021.08.10)函式
- 【每日函式】每日函式(2021.08.05)函式
- 【每日函式】每日函式(2021.08.06)函式
- 【每日函式】每日函式(2021.08.14)函式
- 【每日函式】每日函式(2021.08.08)函式
- 【每日函式】每日函式(2021.08.09)函式
- 【知識點】inline函式、回撥函式、普通函式inline函式
- LOAD_BALANCE&TAF總結
- Python函式與lambda 表示式(匿名函式)Python函式
- hdu 2111 Saving HDU (DP)
- webgl內建函式--幾何函式與矩陣函式Web函式矩陣
- webgl內建函式--向量函式與紋理查詢函式Web函式
- Oracle OCP(03):字元函式、數字函式和日期函式Oracle字元函式
- 深入理解 函式、匿名函式、自執行匿名函式函式
- 箭頭函式、簡寫函式、普通函式的區別函式
- Hive函式(內建函式+自定義標準函式UDF)Hive函式
- webgl內建函式--通用函式Web函式
- Kotlin之“with”函式和“apply”函式Kotlin函式APP
- Kotlin 函式6 - 高階函式Kotlin函式