HDU 1709 The Balance(母函式)

Mr_Treeeee發表於2020-04-06

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8192    Accepted Submission(s): 3430


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
3 1 2 4 3 9 2 1
 

Sample Output
0 2 4 5
 

Source
 

題意:
給你幾個砝碼,一個天平,求出不能稱出的重量,砝碼可以左右放。

POINT:
母函式,其實感覺就是個DP而已。天平可以放兩邊就是減一下。

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <map>
using namespace std;
#define LL long long
const int N = 12000+6;
int c1[N],c2[N];
int a[N];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int sum=0;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]),sum+=a[i];
        memset(c1,0,sizeof c1);
        c1[0]=c1[a[1]]=1;
        for(int i=2;i<=n;i++)
        {
            for(int j=sum;j>=0;j--)
            {
                if(c1[j]==1)
                {
                    c2[j]=1;
                    c2[j+a[i]]=1;
                    c2[abs(j-a[i])]=1;
                }
            }
            for(int j=0;j<=sum;j++) c1[j]=c2[j],c2[j]=0;
        }
        int cnt=0;
        int ans[N];
        for(int i=1;i<=sum;i++)
        {
            if(c1[i]==0)
            {
                ans[++cnt]=i;
            }
        }
        if(cnt==0) printf("0\n");
        else
        {
            printf("%d\n",cnt);
            for(int i=1;i<=cnt;i++)
            {
                if(!(i-1)) printf("%d",ans[i]);
                else printf(" %d",ans[i]);
            }
            printf("\n");
        }
    }
    return 0;
}


相關文章