POJ 2155-Matrix(二維樹狀陣列-區間修改 單點查詢)
Matrix
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 27355 | Accepted: 10003 |
Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.
There is a blank line between every two continuous test cases.
Sample Input
1 2 10 C 2 1 2 2 Q 2 2 C 2 1 2 1 Q 1 1 C 1 1 2 1 C 1 2 1 2 C 1 1 2 2 Q 1 1 C 1 1 2 1 Q 2 1
Sample Output
1 0 0 1
Source
POJ Monthly,Lou Tiancheng
題目意思:
N×N的矩形,元素值只能是0/1。
C X1 Y1 X2 Y2表示將左上角(X1,Y1)和右下角(X2,Y2)構成的矩形內的所有元素值取反;
Q X Y表示查詢點(X,Y)處的元素值。
解題思路:
二位樹狀陣列。
我們往往單點修改,區間查詢,此時update是從小到大,getsum是從大到小;
現在要求區間修改,單點查詢,所以update是從大到小,getsum是從小到大。
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define MAXN 1100
int c[MAXN][MAXN],n;
int lowbit(int x)
{
return x&(-x);
}
void update(int x,int y,int num)//從大到小修改
{
for(int i=x; i>0; i-=lowbit(i))
for(int j=y; j>0; j-=lowbit(j))
c[i][j]+=num;
}
int sum(int x,int y)//從小到大求和
{
int res=0;
for(int i=x; i<=n; i+=lowbit(i))
for(int j=y; j<=n; j+=lowbit(j))
res+=c[i][j];
return res;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("G:/cbx/read.txt","r",stdin);
//freopen("G:/cbx/out.txt","w",stdout);
#endif
int T;
scanf("%d",&T);
while(T--)
{
int t;
char op[2];
memset(c,0,sizeof(c));
scanf("%d%d",&n,&t);
while(t--)
{
scanf("%s",op);
if(op[0]=='C')
{
int x1,y1,x2,y2;
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
update(x1-1,y1-1,1);
update(x2,y2,1);
update(x1-1,y2,-1);
update(x2,y1-1,-1);
}
else if(op[0]=='Q')
{
int x,y;
scanf("%d%d",&x,&y);
printf("%d\n",sum(x,y)%2);
}
}
printf("\n");
}
return 0;
}
相關文章
- 樹狀陣列模板題 & (樹狀陣列 1:單點修改,區間查詢)陣列
- POJ 3468 【區間修改+區間查詢 樹狀陣列 | 線段樹 | 分塊】陣列
- 樹狀陣列的區間查詢與區間修改陣列
- HDU1166 敵兵佈陣【樹狀陣列 單點修改+區間查詢】陣列
- HDU 1556【區間更新+單點查詢 樹狀陣列】陣列
- 線段樹(1)建樹、單點修改、單點查詢、區間查詢和例題
- 二維樹狀陣列陣列
- 二維陣列查詢陣列
- POJ3468 A Simple Problem with Integers---樹狀陣列(區間問題)陣列
- POJ-2352 Stars(樹狀陣列)陣列
- 關於區間操作查詢(字首和與差分)+樹狀陣列基礎陣列
- 二維陣列中的查詢陣列
- HDU 1541 & POJ 2352 Stars (樹狀陣列)陣列
- HDU1166 敵兵佈陣【線段樹基礎:點修改+區間查詢】
- 【JZOF】二維陣列中的查詢陣列
- 芻議線段樹 2 (區間修改,區間查詢)
- HDU1754 I Hate It 【線段樹基礎:點修改+區間查詢】
- 【劍指offer】二維陣列中的查詢陣列
- C108 整體二分+樹狀陣列(區修+區查)P3332 [ZJOI2013] K大數查詢陣列
- HDU 6274 Master of Sequence(思維+樹狀陣列+二分)AST陣列
- 線段樹維護單調棧——區間查詢版本 & 維護遞減序列
- 洛谷題單指南-二叉堆與樹狀陣列-P3368 【模板】樹狀陣列 2陣列
- 求區間不同數的個數【樹狀陣列求解】陣列
- offer通過--3二維陣列中查詢-2陣列
- 【劍指offer】【1】二維陣列中的查詢陣列
- HDU1698 Just a Hook【線段樹基礎:區間修改+區間查詢】Hook
- bzoj3110: [Zjoi2013]K大數查詢(主席樹+樹狀陣列)陣列
- 樹狀陣列陣列
- 二維陣列中的查詢——牛客劍指offer陣列
- nowcoder-劍指offer-二維陣列的查詢陣列
- 劍指 Offer 04. 二維陣列中的查詢陣列
- 劍指 offer 第一題: 二維陣列中的查詢陣列
- 解析樹狀陣列陣列
- JavaSE 陣列:一維陣列&二維陣列Java陣列
- 二維陣列傳參要點陣列
- 【Leetcode每日一題】327. 區間和的個數(線段樹/樹狀陣列)LeetCode每日一題陣列
- 【Java】陣列二分查詢元素Java陣列
- 樹狀陣列詳解陣列
- 樹狀陣列基礎陣列