POJ 1195-Mobile phones(二維樹狀陣列-區間更新區間查詢)
Mobile phones
Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 17661 | Accepted: 8173 |
Description
Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square
contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the
main base station along with the row and the column of the matrix.
Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.
Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.
Input
The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction
integer and a number of parameter integers according to the following table.
The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.
Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30
The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.
Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30
Output
Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to
standard output.
Sample Input
0 4 1 1 2 3 2 0 0 2 2 1 1 1 2 1 1 2 -1 2 1 1 2 3 3
Sample Output
3 4
Source
IOI 2001
1 x y a表示在arr[x][y]加上a;
2 l b r t 表示求左上角為(l,b),右下角為(r,t)的矩陣的和。
題目意思:
有一個矩陣(初始化為0),給出一些操作:1 x y a表示在arr[x][y]加上a;
2 l b r t 表示求左上角為(l,b),右下角為(r,t)的矩陣的和。
解題思路:
裸的二維樹狀陣列區間更新區間查詢#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define MAXN 1100
int c[MAXN][MAXN],n,arr[MAXN][MAXN];
int lowbit(int x)
{
return x&(-x);
}
void update(int x,int y,int num)
{
int i,j;
for(i=x; i<=n; i+=lowbit(i))
for(j=y; j<=n; j+=lowbit(j))
c[i][j]+=num;
}
int sum(int x,int y)
{
int i,j,res=0;
for(i=x; i>0; i-=lowbit(i))
for(j=y; j>0; j-=lowbit(j))
res+=c[i][j];
return res;
}
int getsum(int x1,int y1,int x2,int y2)
{
return sum(x2,y2)-sum(x1-1,y2)-sum(x2,y1-1)+sum(x1-1,y1-1);
}
int main()
{
int op,x,y,l,b,r,t,a;
while(~scanf("%d",&op))
{
if(op==0)
{
scanf("%d",&n);
memset(c,0,sizeof(c));
}
else if(op==1)
{
scanf("%d%d%d",&x,&y,&a);
update(x+1,y+1,a);
}
else if(op==2)
{
scanf("%d%d%d%d",&l,&b,&r,&t);
int ans=getsum(l+1,b+1,r+1,t+1);
printf("%d\n",ans);
}
}
return 0;
}
相關文章
- 【樹狀陣列 區間更新區間查詢】code陣列
- POJ 3468 【區間修改+區間查詢 樹狀陣列 | 線段樹 | 分塊】陣列
- POJ 2155-Matrix(二維樹狀陣列-區間修改 單點查詢)陣列
- 樹狀陣列單點更新和區間查詢陣列
- 樹狀陣列的區間查詢與區間修改陣列
- POJ 1195 Mobile phones(二維樹狀陣列)陣列
- HDU 1556【區間更新+單點查詢 樹狀陣列】陣列
- poj 3237 樹鏈剖分(區間更新,區間查詢)
- 樹狀陣列模板題 & (樹狀陣列 1:單點修改,區間查詢)陣列
- 變化的區間樹狀陣列,單點查詢陣列
- POJ3468 A Simple Problem with Integers---樹狀陣列(區間問題)陣列
- HDU 1556-Color the ball(樹狀陣列-區間修改 單點查詢)陣列
- D 區間求和 [數學 樹狀陣列]陣列
- 【二維樹狀陣列】poj 2155 Matrix陣列
- 二維樹狀陣列-poj2155陣列
- poj 1195 二維樹狀陣列陣列
- 關於區間操作查詢(字首和與差分)+樹狀陣列基礎陣列
- HDU1166 敵兵佈陣【樹狀陣列 單點修改+區間查詢】陣列
- 二維樹狀陣列--poj1195陣列
- HYSBZ 2243 樹鏈剖分(區間更新,區間查詢)較難
- 二維樹狀陣列陣列
- 芻議線段樹 2 (區間修改,區間查詢)
- POJ 3468 A Simple Problem with Integers (線段樹 區間更新)
- 求區間不同數的個數【樹狀陣列求解】陣列
- POJ 2777-Count Color(線段樹-區間染色查詢)
- POJ 3468-A Simple Problem with Integers(區間更新線段樹)
- 【樹狀陣列 區間修改,單點求值】1556 Color the ball陣列
- poj 2481 樹狀陣列陣列
- 二維陣列查詢陣列
- poj 3468 區間更新 整個區間加一個數和區間求和操作
- LintCode 二叉查詢樹中搜尋區間
- 線段樹維護區間等差數列
- JavaScript --二維陣列查詢一維陣列JavaScript陣列
- 日期區間查詢
- spoj375 樹鏈剖分(單點更新,區間查詢)
- 1082 線段樹練習 3 區間查詢與區間修改
- 【樹狀陣列 單點修改,區間求值】hdu 1166 敵兵佈陣陣列
- POJ 2528 Mayor's posters (線段樹 區間更新+離散化)