HDU 4965 Fast Matrix Calculation(矩陣快速冪)

畫船聽雨發表於2014-08-27

題目大意:給你兩個數字n和k,然後給你兩個矩陣a是n*k的和b是k*n的,矩陣c = a*b,讓你求c^(n*n)。

直接求的話c是n*n的矩陣所以是1000*1000,會超時的啊。

可以轉化一下:(a*b)^(n*n)=a*(b*a)^(n*n-1)*b。b*a可以得到一個k*k的矩陣,k很小所以不會超時,快速冪一下就可以了啊。

Fast Matrix Calculation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 717    Accepted Submission(s): 355


Problem Description
One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N). 
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’. 

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.
 

Input
The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.
 

Output
For each case, output the sum of all the elements in M’ in a line.
 

Sample Input
4 2 5 5 4 4 5 4 0 0 4 2 5 5 1 3 1 5 6 3 1 2 3 0 3 0 2 3 4 4 3 2 2 5 5 0 5 0 3 4 5 1 1 0 5 3 2 3 3 2 3 1 5 4 5 2 0 0
 

Sample Output
14 56
 

Author
SYSU
 

Source
 
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-10
///#define M 1000100
///#define LL __int64
#define LL long long
///#define INF 0x7ffffff
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
#define zero(x) ((fabs(x)<eps)?0:x)

using namespace std;

const int maxn = 1010;

#define mod 6

struct matrix
{
    int f[6][6];
};

int A[maxn][maxn];
int B[maxn][maxn];
int C[maxn][maxn];
int D[maxn][maxn];

matrix mul(matrix a, matrix b, int n)
{
    matrix c;
    memset(c.f, 0, sizeof(c.f));
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < n; j++)
        {
            for(int k = 0; k < n; k++) c.f[i][j] += a.f[i][k]*b.f[k][j];
            c.f[i][j] %= 6;
        }
    }
    return c;
}

matrix pow_mod(matrix a, int b, int n)
{
    matrix s;
    memset(s.f, 0 , sizeof(s.f));
    for(int i = 0; i < n; i++) s.f[i][i] = 1;
    while(b)
    {
        if(b&1) s = mul(s, a, n);
        a = mul(a, a, n);
        b >>= 1;
    }
    return s;
}

int main()
{
    int n, k;
    while(cin >>n>>k)
    {
        if(!n && !k) break;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < k; j++) scanf("%d",&A[i][j]);
        for(int i = 0; i < k; i++)
            for(int j = 0; j < n; j++) scanf("%d",&B[i][j]);
        matrix c;
        memset(c.f, 0, sizeof(c.f));
        for(int i = 0; i < k; i++)
        {
            for(int j = 0; j < k; j++)
            {
                for(int jj = 0; jj < n; jj++) c.f[i][j] += B[i][jj]*A[jj][j];
                c.f[i][j] %= mod;
            }
        }
        c = pow_mod(c, n*n-1, k);
        memset(C, 0, sizeof(C));
        memset(D, 0, sizeof(D));
        for(int  i = 0; i < n; i++)
        {
            for(int j = 0; j < k; j++)
            {
                for(int jj = 0; jj < k; jj++) C[i][j] += A[i][jj]*c.f[jj][j];
                C[i][j] %= mod;
            }
        }
        int ans = 0;
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < n; j++)
            {
                for(int jj = 0; jj < k; jj++) D[i][j] += C[i][jj]*B[jj][j];
                D[i][j] %= mod;
                ans += D[i][j];
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


相關文章