POJ 3321 Apple Tree(dfs+樹狀陣列)

畫船聽雨發表於2014-02-26

題目的意思是給你一棵樹上面有很多蘋果,你可以摘蘋果樹也會長蘋果。讓你求出樹上某一節點上所有的蘋果。

從別人那裡看的分析,感覺挺好的:

分析:每個分支其實就是一個節點,先dfs整個樹,求出每個節點的時間戳,即每個節點第一次訪問的時間和最後一次訪問的時間,分別用begin和end記錄,以時間戳為編號,則在begin[x]和end[x]之間的編號的節點就是x的子樹,以時間戳為樹狀陣列的下標,查詢時,只要求第一次訪問的編號到最後一次訪問的編號之間的和就行了,即sum(end[x])-sum(begin[x]-1);修改時,只要修改第一次訪問的編號即可,即update(begin[x])。但是修改前要判斷該位置是0或1,0則加1,1則減1。


Apple Tree
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 17220   Accepted: 5222

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 505000;

using namespace std;

int c[maxn];
int n;
int dfs_clock;
int head[maxn];
int first[maxn];
int last[maxn];
int t;
struct node
{
    int v;
    int next;
}f[maxn];

void ADD(int u, int v)
{
    f[t].v = v;
    f[t].next = head[u];
    head[u] = t++;
}

int lowbit(int x)
{
    return x&(-x);
}

void add(int x, int ad)
{
    while(x <= n)
    {
        c[x] += ad;
        x += lowbit(x);
    }
}

int sum(int x)
{
    int cnt = 0;
    while(x > 0)
    {
        cnt += c[x];
        x -= lowbit(x);
    }
    return cnt;
}

void dfs(int u)
{
    first[u] = ++dfs_clock;
    for(int i = head[u]; i != -1; i = f[i].next)
        dfs(f[i].v);
    last[u] = dfs_clock;
}

int main()
{
    int m;
    scanf("%d",&n);
    int u, v;
    t = 0;
    memset(head, -1, sizeof(head));
    for(int i = 1; i < n; i++)
    {
        scanf("%d %d",&u, &v);
        ADD(u, v);
    }
    dfs_clock = 0;
    dfs(1);
    memset(c, 0 , sizeof(c));
    for(int i = 1; i <= n; i++)
        add(i, 1);
    scanf("%d",&m);
    for(int i = 1; i <= m; i++)
    {
        char str;
        int x;
        scanf("%*c%c",&str);
        if(str == 'Q')
        {
            scanf("%d",&x);
            int ans = sum(last[x])-sum(first[x]-1);
            printf("%d\n",ans);
        }
        else
        {
            scanf("%d",&x);
            if(sum(first[x])-sum(first[x]-1))
                 add(first[x], -1);
             else
                add(first[x], 1);
        }
    }
    return 0;
}



相關文章