POJ 2352 Stars(簡單樹狀陣列)
什麼是樹狀陣列在這裡就不說了啊,這裡有解釋了啊。http://blog.csdn.net/fulongxu/article/details/19701281
就是一個模版題目,直接套模版都可以過。先建陣列,再求和。
由於y座標是升序的且座標不重複,所以在星星A後面輸入的星星的x,y座標不可能都小於等於星星A。假如當前輸入的星星為(3,3),易得我們只需要去找樹狀陣列中小於等於3的值就可以了。
Stars
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 29336 | Accepted: 12829 |
Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars.
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5 1 1 5 1 7 1 3 3 5 5
Sample Output
1 2 1 1 0
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 50000;
using namespace std;
int c[maxn];
int vis[maxn];
int lowbit(int x)
{
return x&(-x);
}
void add(int x)
{
while(x < maxn)
{
c[x]++;
x += lowbit(x);
}
}
int sum(int x)
{
int cnt = 0;
while(x > 0)
{
cnt += c[x];
x -= lowbit(x);
}
return cnt;
}
int main()
{
int n;
while(~scanf("%d",&n))
{
int x, y;
memset(vis, 0 , sizeof(vis));
for(int i = 0; i < n; i++)
{
scanf("%d %d",&x, &y);
x++;
y++;
vis[sum(x)]++;
add(x);
}
for(int i = 0; i < n; i++)
cout<<vis[i]<<endl;
}
return 0;
}
相關文章
- POJ-2352 Stars(樹狀陣列)陣列
- POJ 2352-Stars(樹狀陣列-星系)陣列
- HDU 1541 & POJ 2352 Stars (樹狀陣列)陣列
- POJ 2352(順路講解一下樹狀陣列)陣列
- poj 2481 樹狀陣列陣列
- 【樹狀陣列 求比其小的個數】poj 2353 Stars陣列
- POJ 3928 Ping pong(樹狀陣列)陣列
- 【二維樹狀陣列】poj 2155 Matrix陣列
- 二維樹狀陣列-poj2155陣列
- poj 1195 二維樹狀陣列陣列
- POJ 3321-Apple Tree(樹狀陣列)APP陣列
- 二維樹狀陣列--poj1195陣列
- POJ 3067-Japan(樹狀陣列-逆序數)陣列
- POJ 1195 Mobile phones(二維樹狀陣列)陣列
- POJ 3321 Apple Tree(dfs+樹狀陣列)APP陣列
- 樹狀陣列模板題 & (樹狀陣列 1:單點修改,區間查詢)陣列
- 樹狀陣列陣列
- POJ 3928-Ping pong(樹狀陣列+加/乘法原理)陣列
- POJ3321 Apple Tree(DFS序 + 樹狀陣列)APP陣列
- POJ 2155-Matrix(二維樹狀陣列-區間修改 單點查詢)陣列
- POJ 2299-Ultra-QuickSort(樹狀陣列求逆序數)UI陣列
- 解析樹狀陣列陣列
- POJ3468 A Simple Problem with Integers---樹狀陣列(區間問題)陣列
- POJ 3468 【區間修改+區間查詢 樹狀陣列 | 線段樹 | 分塊】陣列
- 樹狀陣列詳解陣列
- 樹狀陣列基礎陣列
- hdu 3874 樹狀陣列陣列
- 二維樹狀陣列陣列
- 樹狀陣列入門(簡單的原理講解)陣列
- 樹狀陣列和逆序對陣列
- hdu 5147 樹狀陣列陣列
- 樹狀陣列快速入門陣列
- 樹狀陣列單點更新和區間查詢陣列
- AcWing 242. 一個簡單的整數問題(樹狀陣列解法)陣列
- 變化的區間樹狀陣列,單點查詢陣列
- 樹狀陣列模板+習題集陣列
- 樹狀陣列3種基本操作陣列
- 學習筆記----樹狀陣列筆記陣列