POJ 2486 Apple Tree(樹形dp)
題目的大體意思是:一個人從根節點1出發開始吃蘋果,每個節點有num[i]個蘋果。最多可以走k步,求k步以內可以吃到的蘋果的最大值。
分析:對於每一個節點都有兩種可能性存在就是:可以返回,或者不返回之前的節點。
所以有:
dp[0][i][j] 表示:不返回時,到第i個節點走了j步時得到的最大值。
dp[1][i][j] 表示:返回時,到第i個節點走了j步時得到的最大值。
這是一個樹上的分組揹包,注意:不返回時,因為只有一個“出口”走下去,所以有兩種情況:(1)這個點是“出口”;
(2)不是“出口”,所以有:
dp[1][i][j+2] = max( dp[1][i][j+2], dp[1][i][t]+dp[1][x][j-t]);
dp[0][i][j+2] = max(dp[0][i][j+2], dp[0][i][t]+dp[1][x][j-t]);//不是出口
dp[0][i][j+1] = max(dp[0][i][j+1], dp[1][i][t]+dp[0][x][j-t]);//出口
Apple Tree
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 7010 | Accepted: 2335 |
Description
Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX
is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants
to eat as many as she can. Can you tell how many apples she can eat in at most K steps.
Input
There are several test cases in the input
Each test case contains three parts.
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 ... N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.
Input will be ended by the end of file.
Note: Wshxzt starts at Node 1.
Each test case contains three parts.
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 ... N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.
Input will be ended by the end of file.
Note: Wshxzt starts at Node 1.
Output
For each test case, output the maximal numbers of apples Wshxzt can eat at a line.
Sample Input
2 1 0 11 1 2 3 2 0 1 2 1 2 1 3
Sample Output
11 2
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-8
#define M 1000100
//#define LL __int64
#define LL long long
#define INF 0x7ffffff
#define PI 3.1415926535898
const int maxn = 210;
using namespace std;
int n, k;
int num[maxn];
int vis[maxn];
int dp[2][maxn][maxn];
vector<int>g[maxn], f[maxn];
void Del(int x)
{
vis[x] = 1;
for(int i = 0; i < g[x].size(); i++)
{
int y = g[x][i];
if(vis[y])
continue;
f[x].push_back(y);
Del(y);
}
}
void dfs(int x)
{
for(int i = 0; i <= k; i++)
dp[0][x][i] = dp[1][x][i] = num[x];
for(int i = 0; i < f[x].size(); i++)
{
int y = f[x][i];
dfs(y);
for(int j = k; j >= 0; j--)
{
for(int t = 0; t <= j; t++)
{
dp[0][x][j+1] = max(dp[0][x][j+1], dp[1][x][t]+dp[0][y][j-t]);//不返回
dp[0][x][j+2] = max(dp[0][x][j+2], dp[0][x][t]+dp[1][y][j-t]);//不返回
dp[1][x][j+2] = max(dp[1][x][j+2], dp[1][x][t]+dp[1][y][j-t]);//返回
}
}
}
}
int main()
{
while(cin >>n>>k)
{
memset(dp, 0, sizeof(dp));
for(int i = 0; i <= n; i++)
{
f[i].clear();
g[i].clear();
}
for(int i = 1; i <= n; i++)
cin >>num[i];
int x, y;
for(int i = 0; i < n-1; i++)
{
cin >>x>>y;
g[x].push_back(y);
g[y].push_back(x);
}
memset(vis, 0, sizeof(vis));
Del(1);
dfs(1);
cout<<dp[0][1][k]<<endl;
}
}
相關文章
- HDU 6035 Colorful Tree(樹形DP)
- 熟練剖分(tree) 樹形DP
- CF 1029E Tree with Small Distances 樹形DP or 貪心
- 樹形DP!
- 樹形DP
- 樹上染色(樹形dp)
- [筆記]樹形dp筆記
- CF1039D You Are Given a Tree (樹形 dp + 貪心 + 根號分治)
- 樹形DP二三知識
- 樹上的等差數列 [樹形dp]
- [樹形dp][HAOI2015]樹上染色
- Apple Catching POJ - 2385APP
- LayUI—tree樹形結構的使用UI
- TZOJ 8472 : Tree (重鏈剖分+線段樹) POJ 3237
- cf633F. The Chocolate Spree(樹形dp)
- BZOJ 4726 [POI2017]Sabota?:樹形dp
- CCF之網路延時(樹形dp)
- UVA 1220 Party at Hali-Bula (樹形DP)
- POJ 3071 Football(概率DP)
- POJ 3267 The Cow Lexicon(dp)
- 【BZOJ3743】[Coci2015]Kamp 樹形DP
- SDOI2018 榮譽稱號(樹形dp)
- 【動態規劃】樹形DP完全詳解!動態規劃
- ZROJ#398. 【18提高7】隨機遊走(期望dp 樹形dp)隨機
- [ABC337G] Tree Inversion(換根 dp + 值域線段樹)
- E73 樹形DP P3177 [HAOI2015] 樹上染色
- Luogu P3177 樹上染色 [ 藍 ] [ 樹形 dp ] [ 貢獻思維 ]
- 簡單dp -- Common Subsequence POJ - 1458
- POJ1390 Blocks (區間DP)BloC
- bzoj1060: [ZJOI2007]時態同步(樹形Dp)
- Vue+element中Tree樹形控制元件資料失效~Vue控制元件
- Antd:Tree樹形控制元件資料解析(JSON轉換)控制元件JSON
- POJ3252Round Numbers(數位dp)
- Making the Grade POJ - 3666(離散化+dp)
- Vue遞迴元件+Vuex開發樹形元件Tree--遞迴元件Vue遞迴元件
- NOIP2024集訓Day23 DP常見模型4 - 樹形模型
- POJ 3667 Hotel 線段樹
- poj 2667 hotel 線段樹
- 樹:基本樹形