POJ 1195 Mobile phones(二維樹狀陣列)
題意很清晰就是對一個矩陣進行區間的更新與查詢,程式碼寫起來很簡單。就是樹狀陣列存貯方式的原理得知道,感覺樹狀陣列,很強大啊、芳姐給指點的思路,每一個陣列元素的子樹是這個下標二進位制的從右向左第一個1表示之前的元素。比如8->1000所以它可以由0100(4),0110(6),0111(7),組成。詳解看之前的部落格:http://blog.csdn.net/fulongxu/article/details/19701281
裸的二維樹狀陣列,注意輸出是:ans = sum (x2+1,y2+1) - sum(x2+1,y1) - sum(x1,y2+1) + sum (x1,y1);減去多於的然後加上減過兩次的。
Mobile phones
Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 13686 | Accepted: 6348 |
Description
Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The
number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with
the row and the column of the matrix.
Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.
Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.
Input
The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter
integers according to the following table.
The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.
Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30
The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.
Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30
Output
Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input
0 4 1 1 2 3 2 0 0 2 2 1 1 1 2 1 1 2 -1 2 1 1 2 3 3
Sample Output
3 4
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 1500;
using namespace std;
int c[maxn][maxn];
int n;
int lowbit(int x)
{
return x&(-x);
}
void add(int x, int y, int ad)
{
for(int i = x; i <= n; i+= lowbit(i))
for(int j = y; j<= n; j += lowbit(j))
c[i][j] += ad;
}
int sum(int x, int y)
{
int cnt = 0;
for(int i = x; i > 0; i -= lowbit(i))
for(int j = y; j > 0; j -= lowbit(j))
cnt += c[i][j];
return cnt;
}
int main()
{
int num;
while(~scanf("%d",&num))
{
if(num == 0)
{
scanf("%d",&n);
memset(c, 0 , sizeof(c));
}
else if(num == 1)
{
int x, y, ad;
scanf("%d %d %d",&x, &y, &ad);
add(x+1, y+1, ad);
}
else if(num == 2)
{
int l, b, r, t;
scanf("%d %d %d %d",&l, &b, &r, &t);
l++; b++; r++; t++;
int ans = sum(r, t)-sum(l-1, t)-sum(r, b-1)+sum(l-1,b-1);
printf("%d\n",ans);
}
else
break;
}
return 0;
}
相關文章
- POJ 1195-Mobile phones(二維樹狀陣列-區間更新區間查詢)陣列
- poj 1195 二維樹狀陣列陣列
- 二維樹狀陣列--poj1195陣列
- 【二維樹狀陣列】poj 2155 Matrix陣列
- 二維樹狀陣列-poj2155陣列
- 二維樹狀陣列陣列
- poj 2481 樹狀陣列陣列
- POJ 2155-Matrix(二維樹狀陣列-區間修改 單點查詢)陣列
- POJ 3928 Ping pong(樹狀陣列)陣列
- POJ-2352 Stars(樹狀陣列)陣列
- POJ 2352-Stars(樹狀陣列-星系)陣列
- POJ 3321-Apple Tree(樹狀陣列)APP陣列
- POJ 2352 Stars(簡單樹狀陣列)陣列
- HDU 6274 Master of Sequence(思維+樹狀陣列+二分)AST陣列
- HDU 1541 & POJ 2352 Stars (樹狀陣列)陣列
- POJ 3067-Japan(樹狀陣列-逆序數)陣列
- POJ 3321 Apple Tree(dfs+樹狀陣列)APP陣列
- 樹狀陣列陣列
- POJ 3928-Ping pong(樹狀陣列+加/乘法原理)陣列
- POJ3321 Apple Tree(DFS序 + 樹狀陣列)APP陣列
- hdu 4368 樹狀陣列 離線維護陣列
- POJ 2299-Ultra-QuickSort(樹狀陣列求逆序數)UI陣列
- 解析樹狀陣列陣列
- JavaSE 陣列:一維陣列&二維陣列Java陣列
- [php]運用變數引用實現一維陣列轉多維樹狀陣列PHP變數陣列
- POJ3468 A Simple Problem with Integers---樹狀陣列(區間問題)陣列
- POJ 2352(順路講解一下樹狀陣列)陣列
- POJ 3468 【區間修改+區間查詢 樹狀陣列 | 線段樹 | 分塊】陣列
- 樹狀陣列詳解陣列
- 樹狀陣列基礎陣列
- hdu 3874 樹狀陣列陣列
- 二維陣列陣列
- js 一維陣列轉二維陣列JS陣列
- js 二維陣列轉一維陣列JS陣列
- PHP二維陣列轉一維陣列PHP陣列
- 【樹狀陣列 求比其小的個數】poj 2353 Stars陣列
- 利用一維陣列構造二叉樹陣列二叉樹
- 樹狀陣列模板題 & (樹狀陣列 1:單點修改,區間查詢)陣列