POJ 2352-Stars(樹狀陣列-星系)

kewlgrl發表於2017-04-15
Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 46418   Accepted: 20020

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source


題目意思:

給出N個星星的座標,在45°方向上能連成一條線的星星為一個星系的話,如果有M顆星星連成一線則最右上方星星的level是M-1。
例如圖中level=0的星星是1,level=1的星星是2和4,level=2的星星是3,level=3的星星是5。

解題思路:

因為y座標順序給定,所以按輸入處理x座標,每次計算並記錄其左邊的星星的個數,然後對其右邊的所有點更新增一。
注意x可能為0,而樹狀陣列下標從1 開始。

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0xfffffff
#define MAXN 32005
int n;
int c[MAXN],cnt[MAXN];

int lowbit(int x)
{
    return x&(-x);
}
void update(int i,int x)
{
    while(i<MAXN)
    {
        c[i]+=x;
        i+=lowbit(i);
    }
}
int sum(int x)
{
    int i,res=0;//res是權值和
    for(i=x; i>0; i-=lowbit(i))
        res+=c[i];
    return res;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    while(~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        memset(cnt,0,sizeof(cnt));
        for(int i=0; i<n; i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            ++x;//避免橫座標為0的情況
            int t=sum(x);
            ++cnt[t];
            update(x,1);//c[x]之後的全部+1
        }
        for(int i=0; i<n; i++)//輸出
            printf("%d\n",cnt[i]);
    }
    return 0;
}


相關文章