POJ 3067-Japan(樹狀陣列-逆序數)

kewlgrl發表於2017-05-04
Japan
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 27557   Accepted: 7455

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

Source


題目意思:

島國的東西兩側分別有N和M個城市,從南到北依次編號。
在它們之間修建K條公路,計算這些公路之間的交點數量。

解題思路:

我們先按城市編號升序排列,東側相同時按西側升序排列。
這個時候如果一條路和其它路有交點,則Y座標一定要小於前面公路的Y座標,這個時候逆序數就登場啦(๑•ᴗ•๑)
樹狀陣列用來求逆序數,每次計算當前Y與之前的Y的逆序數的個數累加。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define MAXN 500005
int c[MAXN],no,num[MAXN];
struct Node
{
    int x,y;
} a[MAXN];
bool cmp(Node a,Node b)
{
    if(a.x!=b.x) return a.x<b.x;
    return a.y<b.y;
}
int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int v)
{
    while(x<=no)
    {
        c[x]+=v;
        x+=lowbit(x);
    }
}
long long getsum(int x)
{
    long long sum=0;
    while(x)
    {
        sum+=c[x];
        x-=lowbit(x);
    }
    return sum;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    int T,ca=0;
    scanf("%d",&T);
    while(T--)
    {
        long long ans;
        int n,m,k;
        no=-1;
        scanf("%d%d%d",&n,&m,&k);
        memset(c,0,sizeof(c));
        for(int i=0; i<k; i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
            no=max(no,a[i].y);
        }
        sort(a,a+k,cmp);//對輸入的序列排序
        ans=0;
        for(int i=0; i<k; i++)
        {
            ans+=getsum(no)-getsum(a[i].y);
            update(a[i].y,1);
        }
        printf("Test case %d: %I64d\n",++ca,ans);
    }
}


相關文章