POJ 3067-Japan(樹狀陣列-逆序數)
Japan
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 27557 | Accepted: 7455 |
Description
Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast
are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of
crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.
Input
The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the
East coast and second one is the number of the city of the West coast.
Output
For each test case write one line on the standard output:
Test case (case number): (number of crossings)
Test case (case number): (number of crossings)
Sample Input
1 3 4 4 1 4 2 3 3 2 3 1
Sample Output
Test case 1: 5
Source
題目意思:
島國的東西兩側分別有N和M個城市,從南到北依次編號。
在它們之間修建K條公路,計算這些公路之間的交點數量。
解題思路:
我們先按城市編號升序排列,東側相同時按西側升序排列。
這個時候如果一條路和其它路有交點,則Y座標一定要小於前面公路的Y座標,這個時候逆序數就登場啦(๑•ᴗ•๑)
樹狀陣列用來求逆序數,每次計算當前Y與之前的Y的逆序數的個數累加。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define MAXN 500005
int c[MAXN],no,num[MAXN];
struct Node
{
int x,y;
} a[MAXN];
bool cmp(Node a,Node b)
{
if(a.x!=b.x) return a.x<b.x;
return a.y<b.y;
}
int lowbit(int x)
{
return x&(-x);
}
void update(int x,int v)
{
while(x<=no)
{
c[x]+=v;
x+=lowbit(x);
}
}
long long getsum(int x)
{
long long sum=0;
while(x)
{
sum+=c[x];
x-=lowbit(x);
}
return sum;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("G:/cbx/read.txt","r",stdin);
//freopen("G:/cbx/out.txt","w",stdout);
#endif
int T,ca=0;
scanf("%d",&T);
while(T--)
{
long long ans;
int n,m,k;
no=-1;
scanf("%d%d%d",&n,&m,&k);
memset(c,0,sizeof(c));
for(int i=0; i<k; i++)
{
scanf("%d%d",&a[i].x,&a[i].y);
no=max(no,a[i].y);
}
sort(a,a+k,cmp);//對輸入的序列排序
ans=0;
for(int i=0; i<k; i++)
{
ans+=getsum(no)-getsum(a[i].y);
update(a[i].y,1);
}
printf("Test case %d: %I64d\n",++ca,ans);
}
}
相關文章
- POJ 2299-Ultra-QuickSort(樹狀陣列求逆序數)UI陣列
- 樹狀陣列和逆序對陣列
- poj 2481 樹狀陣列陣列
- HDU2689 Sort it (樹狀陣列求逆序數)陣列
- HDU 1394 Minimum Inversion Number (樹狀陣列求逆序數)陣列
- POJ 3928 Ping pong(樹狀陣列)陣列
- HDU 2689 Sort it【樹狀陣列求逆序對】陣列
- POJ-2352 Stars(樹狀陣列)陣列
- 【二維樹狀陣列】poj 2155 Matrix陣列
- 二維樹狀陣列-poj2155陣列
- poj 1195 二維樹狀陣列陣列
- POJ 2352-Stars(樹狀陣列-星系)陣列
- POJ 3321-Apple Tree(樹狀陣列)APP陣列
- POJ 2352 Stars(簡單樹狀陣列)陣列
- 二維樹狀陣列--poj1195陣列
- HDU 1541 & POJ 2352 Stars (樹狀陣列)陣列
- POJ 1195 Mobile phones(二維樹狀陣列)陣列
- POJ 3321 Apple Tree(dfs+樹狀陣列)APP陣列
- 【樹狀陣列 求比其小的個數】poj 2353 Stars陣列
- 樹狀陣列陣列
- POJ 3928-Ping pong(樹狀陣列+加/乘法原理)陣列
- POJ3321 Apple Tree(DFS序 + 樹狀陣列)APP陣列
- 解析樹狀陣列陣列
- LeetCode C++ 劍指 Offer 51. 陣列中的逆序對【歸併排序/樹狀陣列/線段樹】LeetCodeC++陣列排序
- POJ3468 A Simple Problem with Integers---樹狀陣列(區間問題)陣列
- POJ 2352(順路講解一下樹狀陣列)陣列
- D 區間求和 [數學 樹狀陣列]陣列
- POJ 3468 【區間修改+區間查詢 樹狀陣列 | 線段樹 | 分塊】陣列
- 陣列元素逆序陣列
- 樹狀陣列詳解陣列
- 樹狀陣列基礎陣列
- hdu 3874 樹狀陣列陣列
- 二維樹狀陣列陣列
- SPOJ DQUERY (離線數狀陣列||線上主席樹)陣列
- 求區間不同數的個數【樹狀陣列求解】陣列
- 樹狀陣列模板題 & (樹狀陣列 1:單點修改,區間查詢)陣列
- hdu 5147 樹狀陣列陣列
- 【筆記/模板】樹狀陣列筆記陣列