杭電ACM hdu 1171 Big Event in HDU 解題報告(母函式)

小飛_Xiaofei發表於2013-11-30

Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input
2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output
20 10
40 40

Author
lcy


Solution

以下部分的版權歸本人(小飛)所有。所有權利保留。

歡迎轉載,轉載時請註明出處:

http://blog.csdn.net/xiaofei_it/article/details/17041709

本題直接套用母函式模板即可。關於母函式的詳細解釋請看:

http://blog.csdn.net/xiaofei_it/article/details/17042651


程式碼如下:

#include <iostream>
#include <cstring>
using namespace std;
#define MAX 250010
int n,a[MAX],b[MAX],i,j,k,last,last2,v[50],m[50];
int main()
{
	while ((cin>>n)&&n>=0)
	{
		for (i=0;i<n;i++)
			cin>>v[i]>>m[i];
		a[0]=1;
		last=0;
		for (i=0;i<n;i++)
		{
			last2=last+m[i]*v[i];
			memset(b,0,sizeof(int)*(last2+1));
			for (j=0;j<=m[i];j++)
				for (k=0;k<=last;k++)
					b[k+j*v[i]]+=a[k];
			memcpy(a,b,sizeof(int)*(last2+1));
			last=last2;
		}
		for (i=last/2;i>=0&&a[i]==0;i--);
		cout<<last-i<<' '<<i<<endl;
	}
	return 0;
}


相關文章