杭電ACM hdu 1171 Big Event in HDU 解題報告(母函式)
Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer
College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they
have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain
an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time,
you should guarantee that A is not less than B.
Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1
Sample Output
20 10
40 40
Author
lcy
Solution
以下部分的版權歸本人(小飛)所有。所有權利保留。
歡迎轉載,轉載時請註明出處:
http://blog.csdn.net/xiaofei_it/article/details/17041709
本題直接套用母函式模板即可。關於母函式的詳細解釋請看:
http://blog.csdn.net/xiaofei_it/article/details/17042651
程式碼如下:
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 250010
int n,a[MAX],b[MAX],i,j,k,last,last2,v[50],m[50];
int main()
{
while ((cin>>n)&&n>=0)
{
for (i=0;i<n;i++)
cin>>v[i]>>m[i];
a[0]=1;
last=0;
for (i=0;i<n;i++)
{
last2=last+m[i]*v[i];
memset(b,0,sizeof(int)*(last2+1));
for (j=0;j<=m[i];j++)
for (k=0;k<=last;k++)
b[k+j*v[i]]+=a[k];
memcpy(a,b,sizeof(int)*(last2+1));
last=last2;
}
for (i=last/2;i>=0&&a[i]==0;i--);
cout<<last-i<<' '<<i<<endl;
}
return 0;
}
相關文章
- HDU 1709 The Balance(母函式)函式
- 杭電hdu2072
- 杭電HDU2018 奶牛的故事
- 杭電OJ1040解題報告
- HDU-ACM 2024 Day3ACM
- HDU-ACM 2024 Day4ACM
- HDU-ACM 2024 Day2ACM
- HDU 母函式簡單題 - 找單詞/Ignatius and the Princess III/Square Coins/Holding Bin-Laden Captive!函式APT
- HDU 不要62 題解
- HDU - 5879解題文件
- HDU 1848 Fibonacci again and again(SG函式)AI函式
- hdu 2111 Saving HDU (DP)
- HDU 1848 Fibonacci again and again (尼姆博弈+sg函式)AI函式
- 簡單的揹包問題(入門)HDU2602 HDU2546 HDU1864
- HDU100題簡要題解(2080~2089)
- HDU 5795 A Simple Nim (SG函式+打表找規律)函式
- 【記憶優化搜尋/dp】HDU - 6415 - 杭電多校第九場 - Rikka with Nash Equilibrium優化UI
- HDU 6311 - Cover [2018杭電多校聯賽第二場 C](尤拉通路/迴路)
- Shape of HDU
- HDU 3349
- HDU 2052(C語言+註釋)+HDU 2090C語言
- hdu2048遞迴問題遞迴
- hdu2049遞迴問題遞迴
- hdu2045 遞迴水題遞迴
- HDU - 2553 N皇后問題(DFS)
- HDU 3661 Assignments
- hdu 6415 - DP
- HDU4787
- hdu2083
- hdu5540
- HDU 4921 Map
- hdu5532
- HDU 1240 Asteroids!AST
- HDU6415(DP)
- HDU 3400 Line belt
- HDU 1236 排名(Java)Java
- hdu1025javaJava
- hdu1069javaJava
- HDU Find the hotel(RMQ)MQ