杭電ACM hdu 1085 Holding Bin-Laden Captive! 解題報告(母函式)

小飛_Xiaofei發表於2013-11-30

Problem Description

We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 

“Oh, God! How terrible! ”

Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!

Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?

Given some Chinese Coins (硬幣) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”

You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input

Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.

Output

Output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input

1 1 3

0 0 0

Sample Output

4

Author

lcy

Solution

以下部分的版權歸本人(小飛)所有。所有權利保留。

歡迎轉載,轉載時請註明出處:

http://blog.csdn.net/xiaofei_it/article/details/17041467

本題直接套用母函式模板即可。關於母函式的詳細解釋請看:

http://blog.csdn.net/xiaofei_it/article/details/17042651


程式碼如下:

#include <iostream>
#include <cstring>
using namespace std;
int n[3],a[9000],b[9000],i,j,k,last,last2;
int v[3]={1,2,5};
int main()
{
	while ((cin>>n[0]>>n[1]>>n[2])&&(n[0]!=0||n[1]!=0|n[2]!=0))
	{
		a[0]=1;
		last=0;
		for (i=0;i<=2;i++)
		{
			last2=last+n[i]*v[i];
			memset(b,0,sizeof(int)*(last2+1));
			for (j=0;j<=n[i];j++)
				for (k=0;k<=last;k++)
					b[k+j*v[i]]+=a[k];
			memcpy(a,b,sizeof(int)*(last2+1));
			last=last2;
		}
		for (i=0;i<=last;i++)
			if (a[i]==0)
				break;
		cout<<i<<endl;
	}
	return 0;
}


相關文章