ZOJ 3868 GCD Expectation (容斥+莫比烏斯反演)
Edward has a set of n integers {a1,a2,...,an}. He randomly picks a nonempty subset {x1,x2,…,xm} (each nonempty subset has equal probability to be picked), and would like to know the expectation of [gcd(x1,x2,…,xm)]k.
Note that gcd(x1,x2,…,xm) is the greatest common divisor of {x1,x2,…,xm}.
Input
There are multiple test cases. The first line of input contains an integerT indicating the number of test cases. For each test case:
The first line contains two integers n,k (1 ≤ n, k ≤ 106). The second line containsn integers a1, a2,…,an (1 ≤ai ≤ 106).
The sum of values max{ai} for all the test cases does not exceed 2000000.
Output
For each case, if the expectation is E, output a single integer denotesE · (2n - 1) modulo 998244353.
Sample Input
1
5 1
1 2 3 4 5
Sample Output
42
Author: LIN, Xi
Source: The 15th Zhejiang University Programming Contest
題目連結:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5480
題目大意:給一個集合,{xi}為它的一個非空子集,設E為[gcd(x1,x2,…,xm)]k 的期望,求E*(2^n - 1) mod 998244353
題目分析:首先一個有n個元素的集合的非空子集個數為2^n - 1,所以E的分母就是2^n - 1了,因此我們要求的只是E的分子,
設F(x)為gcd(xi) = x的個數,那麼ans = (1^k) * F(1) + (2^k) * F(2) + ... + (ma^k) * F(ma)
下面的問題就是如何快速的計算F(x)了,對於一個集合,先計算出x的倍數的個數,nlogn即可,然後就是基礎的容斥,假設現在要求gcd為1的,那就減去gcd為2的,gcd為3的,注意到6同時是2和3的倍數,也就是6的倍數被減了兩次,所以要加上gcd為6的,前面的係數剛好是數字對應的莫比烏斯函式,看到這題很多用dp來容斥的,其實本質和莫比烏斯函式一樣,但是莫比烏斯函式寫起來真的很簡單,2333333
#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;
int const MOD = 998244353;
int const MAX = 1e6 + 5;
ll two[MAX];
int p[MAX], mob[MAX], num[MAX], cnt[MAX];
bool noprime[MAX];
int n, k, ma, pnum;
void Mobius()
{
pnum = 0;
mob[1] = 1;
for(int i = 2; i < MAX; i++)
{
if(!noprime[i])
{
p[pnum ++] = i;
mob[i] = -1;
}
for(int j = 0; j < pnum && i * p[j] < MAX; j++)
{
noprime[i * p[j]] = true;
if(i % p[j] == 0)
{
mob[i * p[j]] = 0;
break;
}
mob[i * p[j]] = -mob[i];
}
}
}
ll qpow(ll x, ll n)
{
ll res = 1;
while(n != 0)
{
if(n & 1)
res = (res * x) % MOD;
x = (x * x) % MOD;
n >>= 1;
}
return res;
}
void pre()
{
Mobius();
two[0] = 1;
for(int i = 1; i < MAX; i++)
two[i] = two[i - 1] * 2ll % MOD;
}
int main()
{
pre();
int T;
scanf("%d", &T);
while(T --)
{
memset(num, 0, sizeof(num));
memset(cnt, 0, sizeof(cnt));
ma = 0;
int tmp;
scanf("%d %d", &n, &k);
for(int i = 0; i < n; i++)
{
scanf("%d", &tmp);
cnt[tmp] ++;
ma = max(ma, tmp);
}
for(int i = 1; i <= ma; i++)
for(int j = i; j <= ma; j += i)
num[i] += cnt[j]; //求i的倍數的個數
ll ans = 0;
for(int i = 1; i <= ma; i++) //列舉gcd
{
ll sum = 0;
for(int j = i; j <= ma; j += i) //容斥
sum = (MOD + sum % MOD + mob[j / i] * (two[num[j]] - 1) % MOD) % MOD;
ans = (MOD + ans % MOD + (sum * qpow(i, k)) % MOD) % MOD;
}
printf("%lld\n", ans);
}
}
相關文章
- HDU 1695 GCD (容斥 + 莫比烏斯反演)GC
- POJ 3904 Sky Code (容斥+莫比烏斯反演)
- Hackerrank GCD Product(莫比烏斯反演)GC
- HDU 5212 Code (容斥 莫比烏斯反演基礎題)
- Codeforces 548E Mike and Foam (容斥+莫比烏斯反演)
- lg容斥與反演
- BZOJ 2818 Gcd (莫比烏斯反演 或 尤拉函式)GC函式
- ZOJ 3435 Ideal Puzzle Bobble (莫比烏斯反演基礎題)Idea
- 洛谷 P2257 YY的GCD(莫比烏斯反演)GC
- 莫比烏斯反演
- SPOJ PGCD - Primes in GCD Table (好題! 莫比烏斯反演+分塊求和優化)GC優化
- BZOJ 2301 [HAOI2011]Problem b (容斥+莫比烏斯反演+分塊優化 詳解)優化
- HDU 1695-GCD(容斥原理+尤拉函式)GC函式
- FZU 1969 && UVA 11426 GCD Extreme (尤拉函式 或 莫比烏斯反演)GCREM函式
- 莫比烏斯反演學習筆記筆記
- 比較典的莫比烏斯反演
- 有標號DAG計數 [容斥原理 子集反演 組合數學 fft]FFT
- 容斥
- 狄利克雷卷積 & 莫比烏斯反演卷積
- HDU 4746 Mophues (莫比烏斯反演應用)
- ZOJ 4846 GCD Reduce (數學分析題)GC
- 反射容斥反射
- 容斥原理
- 狄利克雷卷積與莫比烏斯反演卷積
- 演算法隨筆——數論之莫比烏斯反演演算法
- 【模板】容斥原理
- 容斥原理講解
- Min-Max 容斥
- CSU 1325 A very hard problem (莫比烏斯反演+分塊求和優化)優化
- SPOJ VLATTICE Visible Lattice Points (莫比烏斯反演基礎題)
- Codeforces 235E Number Challenge (神定理+莫比烏斯反演)
- 遊戲裡面的容斥原理遊戲
- 容斥原理學習筆記筆記
- 容斥原理——數學知識
- #19. 計數(容斥原理)
- HDU 4059 The Boss on Mars ( 容斥原理)
- BZOJ 3309 DZY Loves Math (莫比烏斯反演的應用 好題)
- Expectation Maximization AlgorithmGo