POJ1142 Smith Numbers(數論,分治+暴力,質因數分解)

riba2534發表於2018-01-29

Description

While skimming his phone directory in 1982, Albert Wilansky, a
mathematician of Lehigh University,noticed that the telephone number
of his brother-in-law H. Smith had the following peculiar property:
The sum of the digits of that number was equal to the sum of the
digits of the prime factors of that number. Got it? Smith’s telephone
number was 493-7775. This number can be written as the product of its
prime factors in the following way: 4937775= 3*5*5*65837

The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and
the sum of the digits of its prime factors is equally
3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he
named this kind of numbers after his brother-in-law: Smith numbers.
As this observation is also true for every prime number, Wilansky
decided later that a (simple and unsophisticated) prime number is not
worth being a Smith number, so he excluded them from the definition.
Wilansky published an article about Smith numbers in the Two Year
College Mathematics Journal and was able to present a whole collection
of different Smith numbers: For example, 9985 is a Smith number and so
is 6036. However,Wilansky was not able to find a Smith number that was
larger than the telephone number of his brother-in-law. It is your
task to find Smith numbers that are larger than 4937775!

Input

The input file consists of a sequence of positive integers, one
integer per line. Each integer will have at most 8 digits. The input
is terminated by a line containing the number 0.

Output

For every number n > 0 in the input, you are to compute the smallest
Smith number which is larger than n,and print it on a line by itself.
You can assume that such a number exists.

Sample Input

4937774
0

Sample Output

4937775

思路

首先題目定義了一個史密斯數,這個數的定義是:

  • 一個合數的各個位置上加起來的和等於它的素因數所有位置上的數字加起來的和。

比如:

4937775=355658374+9+3+7+7+7+5=3+5+5+6+5+8+3+7=42
4937775=3*5*5*65837\\ 4+9+3+7+7+7+5=3+5+5+6+5+8+3+7=42

題目讓你找出比n大的數中最小的這個數。另外:素數不是史密斯數

直接暴力就好,利用遞迴。

程式碼

#include <cstdio>
#include <cstring>
#include <cctype>
#include <stdlib.h>
#include <string>
#include <map>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
#define inf 1000000
#define mem(a,b) memset(a,b,sizeof(a))

bool isprime(int x)
{
    int m=(int)(sqrt((double)x)+0.5);
    for(int i=2; i<=m; i++)
        if(x%i==0)
            return false;
    return true;
}

int get_digit_sum(int x)
{
    int ans=0;
    while(x)
    {
        ans+=x%10;
        x/=10;
    }
    return ans;
}
int cut(int x)
{
    if(isprime(x))
        return get_digit_sum(x);
    int m=(int)(sqrt((double)x)+0.5);
    for(int i=m; i>=2; i--)
        if(x%i==0)
            return cut(i)+cut(x/i);
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        while(n++)
        {
            if(!isprime(n)&&cut(n)==get_digit_sum(n))
                break;
        }
        printf("%d\n",n);
    }
    return 0;
}

相關文章