POJ 1703-Find them, Catch them(並查集)

kewlgrl發表於2017-05-04
Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 45008   Accepted: 13862

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source


題目意思:

一共有倆犯罪團伙,N個人中有人可能是罪犯,D a b表示a和b屬於同一個犯罪團伙,A a b表示詢問a和b的團伙關係。

解題思路:

反正就倆犯罪團伙,標記set[a]和set[a+n]分別是兩個犯罪團伙。
合併時如果不是其中一派,那就是另外一派;查詢時如果不是其中一派還可能自成一派。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const long N=100000+5;
int m,n;
int set[N+N];
int set_find(int d)
{
    if(set[d]<0) return d;
    return set[d]=set_find(set[d]);
}
void unite(int p,int q)
{
    p=set_find(p);
    q=set_find(q);
    if(p!=q) set[p]=q;
}
int main()
{
    int T,i;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(set,-1,sizeof(set));//初始化時各成一派
        for(i=0; i<m; ++i)
        {
            int a,b;
            char s[5];
            scanf("%s%d%d",s,&a,&b);
            if(s[0]=='A')//詢問
            {
                if(set_find(a)!=set_find(b)&&set_find(a)!=set_find(b+n))
                    printf("%s\n","Not sure yet.");
                else if(set_find(a)==set_find(b))
                    printf("%s\n","In the same gang.");
                else
                    printf("%s\n","In different gangs.");
            }
            else//合併
            {
                unite(a,b+n);
                unite(b,a+n);
            }
        }
    }
    return 0;
}


相關文章